MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000009VCMIMechanics - Objectspublic2009-10-02 06:152010-03-02 10:21
ReporterSteven Aus 
Assigned ToWarmonger 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.74 
Target VersionFixed in Version0.8 
Summary0000009: Creature banks on first visit say they are deserted, and the type (name) of creature bank is not inserted into that dialogue.
DescriptionAs in summary.
TagsNo tags attached.
Attached Files7z file icon Back for Revenge Saves.7z [^] (134,678 bytes) 2009-10-03 12:34
7z file icon Thousand Islands Saves.7z [^] (127,146 bytes) 2009-10-03 12:54

- Relationships
parent of 0000221closedWarmonger Derelict Ship doesn't function anymore after loading a saved game 
parent of 0000278closedWarmonger Pyramid Crash 
has duplicate 0000165closedWarmonger Bug creatures banks don't work 

-  Notes
(0000025)
Warmonger (administrator)
2009-10-03 10:53

Not reproductible, works as it worked before. Please give more details.
(0000029)
Steven Aus (reporter)
2009-10-03 12:35

In my first game in VCMI 0.74, using the Back for Revenge map, the Creature Banks seemed to be corrupted or not working properly ("Back for Revenge" save files). But I started the same map again today ("Back for Revenge - Edric 1-1" save files) and I didn't get that same error. Attached are both starting saves.
(0000030)
Steven Aus (reporter)
2009-10-03 13:10

Interesting. One starting save on "Thousand Islands" map (with Castles - Sylvia as human's chosen starting hero) appears to have no Creature Bank corruption (at least from right-click information and the correct dialog that gives you a chance to fight the guardians), and a different starting save from the same map (with Fortresses - Bron as human's chosen starting hero) has all the Creature Banks as empty and unnamed in the dialog (and right-click information simply saying "Visited"). So it looks like we have an intermittent bug.
(0000031)
Warmonger (administrator)
2009-10-03 14:13
edited on: 2009-10-04 06:09

Confirmed. Crypt bank config is corrupted, now it's all about finding out why.

It does not happpen on first day only.

(0000245)
Warmonger (administrator)
2009-11-21 15:36

Does it only occur after loading saved game?
(0000247)
Zamolxis (viewer)
2009-11-21 15:40

Bug behavior seems very similar to 0000221 indeed, so I'm placing my money on "loading a saved game" group of bugs. ;)

I'm not sure if Steven will pass by today to check and confirm, but if you can reproduce it on your side only with saved games, I think it's safe to assume that's the cause of it.
(0000248)
Warmonger (administrator)
2009-11-21 15:42

I think I got it. Bank config was just not saved.
(0000249)
Warmonger (administrator)
2009-11-21 15:46

Please reopen if necessary.
(0000252)
Zamolxis (viewer)
2009-11-21 15:56

I'll double check in the next release.

A small request though: for a clear trail, can you please add to the comment "fixed in SVN/rXXXX" when marking an item as fixed?
(0000320)
Zamolxis (viewer)
2009-11-29 20:28
edited on: 2009-11-29 20:29

It's not yet solved in 0.74c:

- After loading a saved game, all creature banks show as "Visited"

- When visiting, we have again the "%" character instead of the name for some of them. For example, when visiting Dragon's Utopia, the message says "You have found what was once a %s, but it has been deserted for some time."

(0000356)
Boulie (reporter)
2009-12-02 16:01

Still the same in 0.75.
Creatures banks are "visited" after load game even if weren't

Same situation with Shipwreck and Derelict Ship, so bug no 0000221 should be reopened.
(0000360)
Warmonger (administrator)
2009-12-02 17:38

221 is exactly the same bug, no need to multiplicate beeings.
(0000522)
Warmonger (administrator)
2009-12-29 15:17

Finally fixed in revision 1403
(0000721)
Zamolxis (viewer)
2010-03-02 10:21

Checked and confirmed as fixed in 0.8 (for new or loaded game)

- Issue History
Date Modified Username Field Change
2009-10-02 06:15 Steven Aus New Issue
2009-10-02 10:40 Tow dragon Category Mechanics - objects =>
2009-10-02 12:13 Warmonger Status new => assigned
2009-10-02 12:13 Warmonger Assigned To => Warmonger
2009-10-02 12:22 Zamolxis Product Version => 0.74
2009-10-02 13:47 Zamolxis Category Mechanics - objects =>
2009-10-03 10:53 Warmonger Note Added: 0000025
2009-10-03 10:53 Warmonger Reproducibility always => unable to reproduce
2009-10-03 10:53 Warmonger Status assigned => feedback
2009-10-03 12:34 Steven Aus File Added: Back for Revenge Saves.7z
2009-10-03 12:35 Steven Aus Note Added: 0000029
2009-10-03 12:54 Steven Aus File Added: Thousand Islands Saves.7z
2009-10-03 13:10 Steven Aus Note Added: 0000030
2009-10-03 14:13 Warmonger Note Added: 0000031
2009-10-03 14:13 Warmonger Status feedback => confirmed
2009-10-04 06:09 Warmonger Note Edited: 0000031 View Revisions
2009-10-15 22:03 Zamolxis Relationship added has duplicate 0000165
2009-11-21 15:36 Warmonger Note Added: 0000245
2009-11-21 15:40 Zamolxis Note Added: 0000247
2009-11-21 15:42 Warmonger Note Added: 0000248
2009-11-21 15:43 Warmonger Relationship added parent of 0000221
2009-11-21 15:46 Warmonger Note Added: 0000249
2009-11-21 15:46 Warmonger Status confirmed => resolved
2009-11-21 15:46 Warmonger Fixed in Version => SVN
2009-11-21 15:46 Warmonger Resolution open => fixed
2009-11-21 15:56 Zamolxis Note Added: 0000252
2009-11-29 20:28 Zamolxis Note Added: 0000320
2009-11-29 20:28 Zamolxis Status resolved => feedback
2009-11-29 20:28 Zamolxis Resolution fixed => reopened
2009-11-29 20:28 Zamolxis Note Edited: 0000320 View Revisions
2009-11-29 20:29 Zamolxis Note Edited: 0000320 View Revisions
2009-12-02 10:59 Warmonger Relationship added parent of 0000278
2009-12-02 16:01 Boulie Note Added: 0000356
2009-12-02 17:38 Warmonger Note Added: 0000360
2009-12-29 15:17 Warmonger Note Added: 0000522
2009-12-29 15:17 Warmonger Status feedback => resolved
2009-12-29 15:17 Warmonger Fixed in Version 0.75 => 0.89
2009-12-29 15:17 Warmonger Resolution reopened => fixed
2010-03-02 10:21 Zamolxis Note Added: 0000721
2010-03-02 10:21 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean