MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000278VCMIMechanics - Objectspublic2009-12-02 10:522010-03-02 10:36
ReporterSteven Aus 
Assigned ToWarmonger 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.75 
Target VersionFixed in Version0.8 
Summary0000278: Pyramid Crash
DescriptionWhen Clancy visits the Pyramid called "Object", the dialog has the Pyramid enter text, however if you choose to enter, nothing happens and the game crashes when you try to move after visiting the Pyramid.
TagsNo tags attached.
Attached Files7z file icon Pyramid Crash.7z [^] (231,199 bytes) 2009-12-02 10:52

- Relationships
related to 0000403closedWarmonger Pyramid is still displayed as "Object" in its info window 
child of 0000009closedWarmonger Creature banks on first visit say they are deserted, and the type (name) of creature bank is not inserted into that dialogue. 

-  Notes
(0000350)
Warmonger (administrator)
2009-12-02 10:59
edited on: 2009-12-02 11:00

I presume it happens only after game load?

(0000351)
Steven Aus (reporter)
2009-12-02 11:13

I visited the Pyramid with Clancy, and said yes to enter the Pyramid - then nothing happened, until I tried to move and the game then crashed.
(0000352)
Warmonger (administrator)
2009-12-02 11:38

But that's not what I ask. Does it happen before you load the game?
(0000354)
Steven Aus (reporter)
2009-12-02 12:10

With the attached save you need to trigger it afterwards. It is possible to *attempt* to save afterwards, but the game state is obviously corrupted as three tries I've had to save, have not saved (no message appears on screen and no save files get created).
(0000361)
Warmonger (administrator)
2009-12-02 17:40

We already know that bank configs are not saved, tell me if it's a new bug or close it.
(0000366)
Steven Aus (reporter)
2009-12-02 21:28
edited on: 2009-12-02 21:32

Well, with the other banks, it just says it's empty (without crashing). With the Pyramid it gives a hard crash, that happens every time after choosing to visit. As Tow said, crash bugs need to be given high priority to fix, especially if they are reproducible, as this one is. I can imagine players visiting the "Object (Not visited)" Pyramid and choosing to enter (because there is the apparent option), causing a reproducible crash. I think this needs to be fixed quite quickly. =)

What do you think?

(0000524)
Warmonger (administrator)
2009-12-29 17:16

Fixed in revision 1406
(0000722)
Zamolxis (viewer)
2010-03-02 10:36

Checked and verified as fixed in 0.8 (for new and saved game).

The side issue remaining with object name has been reported separately as 0000403.

- Issue History
Date Modified Username Field Change
2009-12-02 10:52 Steven Aus New Issue
2009-12-02 10:52 Steven Aus File Added: Pyramid Crash.7z
2009-12-02 10:58 Warmonger Assigned To Tow => Warmonger
2009-12-02 10:59 Warmonger Relationship added child of 0000009
2009-12-02 10:59 Warmonger Note Added: 0000350
2009-12-02 11:00 Warmonger Note Edited: 0000350 View Revisions
2009-12-02 11:13 Steven Aus Note Added: 0000351
2009-12-02 11:38 Warmonger Note Added: 0000352
2009-12-02 12:10 Steven Aus Note Added: 0000354
2009-12-02 17:40 Warmonger Note Added: 0000361
2009-12-02 21:28 Steven Aus Note Added: 0000366
2009-12-02 21:32 Steven Aus Note Edited: 0000366 View Revisions
2009-12-29 17:16 Warmonger Note Added: 0000524
2009-12-29 17:16 Warmonger Status assigned => resolved
2009-12-29 17:16 Warmonger Fixed in Version => 0.89
2009-12-29 17:16 Warmonger Resolution open => fixed
2010-03-02 10:35 Zamolxis Issue cloned: 0000403
2010-03-02 10:35 Zamolxis Relationship added related to 0000403
2010-03-02 10:36 Zamolxis Note Added: 0000722
2010-03-02 10:36 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean