MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002025VCMIGUI - PreGamepublic2015-01-03 20:302016-11-11 08:22
ReporterKroArtem 
Assigned ToAVS 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionfixed 
Platformx86_64OSUbuntuOS Version14.10
Product Version0.97b 
Target VersionFixed in Version0.97c 
Summary0002025: pure virtual method called
DescriptionThere was a problem with pure virtual method called and it seemed now it's fixed, but sometimes it still seem to call a virtual method on startup.
vcmi marked 0.97c by Warmonger
Additional Information[New Thread 0x7fffdb44b700 (LWP 7865)]
[Thread 0x7fffe4d4a700 (LWP 7859) exited]
Warning: IntObject re-activated with mismatching used and active
pure virtual method called
terminate called without an active exception

Program received signal SIGABRT, Aborted.
0x00007ffff3ce3e37 in __GI_raise ([email protected]=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: Нет такого файла или каталога.
(gdb) bt
#0 0x00007ffff3ce3e37 in __GI_raise ([email protected]=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007ffff3ce5528 in __GI_abort () at abort.c:89
0000002 0x00007ffff45f005d in __gnu_cxx::__verbose_terminate_handler() ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
0000003 0x00007ffff45eded6 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
0000004 0x00007ffff45edf21 in std::terminate() ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
0000005 0x00007ffff45eea6f in __cxa_pure_virtual ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
0000006 0x0000000000492711 in operator() (__closure=<optimized out>,
    target=<optimized out>)
    at /build/buildd/vcmi-0.97+git20141227.3838~ubuntu14.10.1/client/gui/CGuiHandler.cpp:417
0000007 std::_Function_handler<void(IUpdateable*), CGuiHandler::renderFrame()::<lambda(IUpdateable*)> >::_M_invoke(const std::_Any_data &, IUpdateable *) (
    __functor=..., __args#0=<optimized out>)
    at /usr/include/c++/4.9/functional:2039
0000008 0x00000000006060f6 in operator() (__args#0=0xd9fea0, this=0x7fffffffd140)
    at /usr/include/c++/4.9/functional:2439
0000009 CGPreGame::runLocked(std::function<void (IUpdateable*)>) (this=0xd9fe30,
    cb=...)
    at /build/buildd/vcmi-0.97+git20141227.3838~ubuntu14.10.1/client/CPreGame.cp---Type <return> to continue, or q <return> to quit---
p:549
0000010 0x00000000004931b1 in CGuiHandler::renderFrame (
    [email protected]=0x93dc40 <GH>)
    at /build/buildd/vcmi-0.97+git20141227.3838~ubuntu14.10.1/client/gui/CGuiHandler.cpp:431
0000011 0x0000000000440a15 in mainLoop ()
    at /build/buildd/vcmi-0.97+git20141227.3838~ubuntu14.10.1/client/CMT.cpp:1197
0000012 main (argc=<optimized out>, argv=0x7fffffffde88)
    at /build/buildd/vcmi-0.97+git20141227.3838~ubuntu14.10.1/client/CMT.cpp:485
(gdb)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005447)
SXX (administrator)
2015-02-11 01:00

Is it happen for you in single player?

I just wonder because today I decide to test MP and this problem appear... :-(
(0005451)
KroArtem (updater)
2015-02-11 22:30

Yes, in SP, I didn't test it in MP, though.
(0005452)
SXX (administrator)
2015-02-12 08:49

Thanks. In MP it's currently happen every time.
(0005505)
SXX (administrator)
2015-02-15 04:46

@AVS has fixed this one:
https://github.com/vcmi/vcmi/commit/b71d985d49fec833183b819bf7f8ec9cd33ef3b1 [^]
https://github.com/vcmi/vcmi/commit/c46999bcb86c0445f65a1e81ee5ed1a39c621914 [^]

A least it's way better now.

- Issue History
Date Modified Username Field Change
2015-01-03 20:30 KroArtem New Issue
2015-01-03 20:30 KroArtem Status new => assigned
2015-01-03 20:30 KroArtem Assigned To => Tow
2015-02-11 01:00 SXX Note Added: 0005447
2015-02-11 22:30 KroArtem Note Added: 0005451
2015-02-12 08:49 SXX Note Added: 0005452
2015-02-15 04:46 SXX Note Added: 0005505
2015-02-15 04:46 SXX Assigned To Tow => AVS
2015-02-16 10:52 SXX Status assigned => resolved
2015-02-16 10:52 SXX Fixed in Version => 0.97c
2015-02-16 10:52 SXX Resolution open => fixed
2016-11-11 08:22 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean