MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000010VCMIMechanics - Objectspublic2009-10-02 07:142010-07-13 13:24
ReporterOnionKnight 
Assigned ToTow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.74 
Target VersionFixed in Version0.75 
Summary0000010: Cartographers do not correctly reveal grounds.
DescriptionUnderground cartographer should reveal all subterranean ground, surface cartographers other land grounds and sea cartographers sea on both levels.
Right now underground and above ground cartographers reveal all ground on the current level, and sea cartographers reveal sea at the current level.
Additional InformationOriginally reported on the forum as 0.73c#41: http://forum.vcmi.eu/viewtopic.php?p=3686#3686 [^]
TagsNo tags attached.
Attached Files? file icon Cartographer Test.h3m [^] (12,150 bytes) 2009-10-02 13:01

- Relationships
related to 0000210closedTow Cartographer disappears from map after load 
related to 0000331closedWarmonger At the Underworld Cartographer we get the same message as the one from the Surface Cartographer. 
related to 0000534closedTow Cartographers work incorrectly again (can lead to crash) 

-  Notes
(0000008)
Warmonger (administrator)
2009-10-02 12:33

This issue is known, however original implementation appears troublesome and illogical.
(0000013)
OnionKnight (developer)
2009-10-02 13:03

Since I had a test map I thought I'd upload it. It has every cartographer and terrain on each level.
(0000225)
Tow (developer)
2009-11-14 20:17

Fixed in r1361. It was simply a matter of using subID value.

OnionKnight -> Thanks for the test map!
(0000527)
Zamolxis (viewer)
2009-12-30 07:42

Verified and confirmed as fixed in 0.75.

The only issue remaining is the message for the Underworld Cartographer. I have opened ticket 0000331 for that, so this can be closed.

- Issue History
Date Modified Username Field Change
2009-10-02 07:14 OnionKnight New Issue
2009-10-02 07:14 OnionKnight Note Added: 0000002
2009-10-02 07:14 OnionKnight Note Deleted: 0000002
2009-10-02 07:15 OnionKnight Tag Attached: 0.74
2009-10-02 10:40 Tow dragon Category Mechanics - objects =>
2009-10-02 12:22 Zamolxis Product Version => 0.74
2009-10-02 12:25 Warmonger Status new => acknowledged
2009-10-02 12:33 Warmonger Note Added: 0000008
2009-10-02 13:01 OnionKnight File Added: Cartographer Test.h3m
2009-10-02 13:03 OnionKnight Note Added: 0000013
2009-10-02 13:47 Zamolxis Category Mechanics - objects =>
2009-10-16 02:22 Zamolxis Additional Information Updated View Revisions
2009-11-07 18:26 Warmonger Relationship added related to 0000210
2009-11-14 20:17 Tow Note Added: 0000225
2009-11-14 20:17 Tow Status acknowledged => resolved
2009-11-14 20:17 Tow Fixed in Version => SVN
2009-11-14 20:17 Tow Resolution open => fixed
2009-11-14 20:17 Tow Assigned To => Tow
2009-12-22 14:18 Zamolxis Note Added: 0000437
2009-12-22 14:18 Zamolxis Tag Detached: 0.74
2009-12-30 07:39 Zamolxis Issue cloned: 0000331
2009-12-30 07:39 Zamolxis Relationship added related to 0000331
2009-12-30 07:42 Zamolxis Note Deleted: 0000437
2009-12-30 07:42 Zamolxis Note Added: 0000527
2009-12-30 07:42 Zamolxis Status resolved => closed
2010-07-13 13:24 Zamolxis Issue cloned: 0000534
2010-07-13 13:24 Zamolxis Relationship added related to 0000534

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean