MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000012VCMIGUI - PreGamepublic2009-10-02 08:312009-12-22 12:23
Reporterbeholder 
Assigned ToTow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.74 
Target VersionFixed in Version0.75 
Summary0000012: Clicking in the first column doesn't change map
Descriptionclicking in the first column in the scenario list doesn't change selected map



TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000010)
OnionKnight (developer)
2009-10-02 12:46

The double-click sound could be related to my change in revision 1196. I suspect the click sound is first played when the list is sorted/filtered and then played again when the first element in the list is selected.

I think this issue should be broken out into more smaller issues as they're not all that related to each other code-wise.
(0000022)
beholder (reporter)
2009-10-02 15:38

ok
I would be nice if I could assign this ticket to you after replying. Also editing could be nice - will you break this ticket into pieces ;) or should I do it?
(0000023)
OnionKnight (developer)
2009-10-02 15:57

It's best if you split it as you see fit since you're the one who identified the bugs. I haven't yet looked into the issue of sounds (I have barely looked at anything regarding sound effects, really) but I'll assign myself if I believe I can resolve it.
(0000035)
Zamolxis (viewer)
2009-10-04 00:27

As this was a multiple-bug report, I broke it into several reports (as explained below) and kept this one only for the one item which I didn't understand what was it referring to (and perhaps beholder could clarify):

Items in the original report:

- when selecting scenario you hear double-click sound instead of single click [recreated as 0000078]
- clicking on the first column doesn't change map [remains to be handled as 0000012 - more explanation from the submitter needed]

Show Advanced Options:
- no clicking sounds [recreated as 0000077, with new detailed descriptions]
- when right clicking on hero there is no string description of hero speciality [recreated as 0000082]
- no human/cpu info [recreated as 0000080]
(0000036)
Zamolxis (viewer)
2009-10-04 00:31

Hi beholder,

Regarding the item left to be handled as 0000012 - "clicking on the first column doesn't change map" - judging by the content of your report, by "first column" my guess was that you were referring to the 1st column in the Scenario List, which is "Number of Players". But for me clicking on that changes the selected map. Can you please clarify what was it referring to?
(0000040)
beholder (reporter)
2009-10-04 16:50

That's it. When I click on any row in first column (number of players eg. "2/1") then map isn`t changed for that one (no change at all).
Moreover now I see that there`s no clicking sound either.
(0000043)
Zamolxis (viewer)
2009-10-04 19:59
edited on: 2009-10-04 20:04

No clicking sounds in that interface was reported as part of 0000077.

As for clicking in the first column, now I see what you mean. First I thought you were referring to clicking on the column header (which changes the default map selected). But I see now you mean clicking in that column on the line of a certain map. In that case I can reproduce it, but this is actually normal H3 behavior. I'm not sure if this was a H3 "bug", or for some reason intended so. We'll let the devs decide on this. ;)

For now, I've updated the report summary & description from "clicking on..." to "clicking in the first column...", to make it clear that it's not because of clicking on the column header.

(0000047)
Tow (developer)
2009-10-06 00:32

Fixed in r1282
(0000424)
Zamolxis (viewer)
2009-12-22 12:23

Verified in 0.75. Fix confirmed and no related issues pending.

- Issue History
Date Modified Username Field Change
2009-10-02 08:31 beholder New Issue
2009-10-02 12:23 Zamolxis Product Version => 0.74
2009-10-02 12:46 OnionKnight Note Added: 0000010
2009-10-02 13:45 Zamolxis Category GUI - other =>
2009-10-02 14:22 OnionKnight Status new => feedback
2009-10-02 15:38 beholder Note Added: 0000022
2009-10-02 15:57 OnionKnight Note Added: 0000023
2009-10-03 23:19 Zamolxis Description Updated View Revisions
2009-10-04 00:07 Zamolxis Relationship added related to 0000078
2009-10-04 00:16 Zamolxis Issue cloned: 0000080
2009-10-04 00:16 Zamolxis Relationship added parent of 0000080
2009-10-04 00:20 Zamolxis Relationship added parent of 0000082
2009-10-04 00:27 Zamolxis Note Added: 0000035
2009-10-04 00:27 Zamolxis Summary map select screen clicking => Clicking on the first column doesn't change map
2009-10-04 00:27 Zamolxis Description Updated View Revisions
2009-10-04 00:31 Zamolxis Note Added: 0000036
2009-10-04 16:50 beholder Note Added: 0000040
2009-10-04 19:59 Zamolxis Note Added: 0000043
2009-10-04 20:02 Zamolxis Summary Clicking on the first column doesn't change map => Clicking in the first column doesn't change map
2009-10-04 20:02 Zamolxis Description Updated View Revisions
2009-10-04 20:04 Zamolxis Note Edited: 0000043 View Revisions
2009-10-06 00:30 Tow Assigned To => Tow
2009-10-06 00:30 Tow Category GUI - Other => GUI - PreGame
2009-10-06 00:32 Tow Note Added: 0000047
2009-10-06 00:32 Tow Status feedback => resolved
2009-10-06 00:32 Tow Fixed in Version => SVN
2009-10-06 00:32 Tow Resolution open => fixed
2009-12-22 12:22 Zamolxis Relationship deleted parent of 0000080
2009-12-22 12:22 Zamolxis Relationship deleted parent of 0000082
2009-12-22 12:22 Zamolxis Relationship deleted related to 0000078
2009-12-22 12:23 Zamolxis Note Added: 0000424
2009-12-22 12:23 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean