MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001945VCMIMechanics - Objectspublic2014-11-11 11:412016-01-17 12:35
ReporterSebt 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformTablet ASUS TF201OSAndroidOS Version4.1.1.
Product Version0.97 
Target VersionFixed in Version0.97c 
Summary0001945: Crash when learning skill from University or Magic Univercity
DescriptionGame crash when trying to learnqa new skill from Univercity on adventure map or from Conflux's Magic Univercity. Any hero, any map, any time, always.

After clicking buy, you exit chosen skill window and see Univercity window again, but skill doesn't turn "gold", shortly after buying skill crash happens.
Steps To ReproduceClick to buy skill in certain building.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001899closedSXX in this map when I visit the hill fort - crash 
related to 0001991closedSXX Conflux error 

-  Notes
(0005118)
Noui (reporter)
2014-11-17 11:15

Confirmed, I get this crash as well
(0005356)
SXX (administrator)
2015-01-07 11:13

@Warmonger if you not looking into this one I'll fix this one. :-)

At moment problem is pretty easy:
1 - First of all server-side always get SecondarySkill::PATHFINDING when player attempt to buy skill.
2 - There also possible some issue with "availableItemsIds" check.
(0005357)
SXX (administrator)
2015-01-07 11:50

Funny, but it's exactly same bug like with 0001899.

There is lambda function that use local variable which end up being garbage, but likely in process of network request it's become 0. Also once fixed it's looks like availableItemsIds check start to work as expected too.
(0005358)
Warmonger (administrator)
2015-01-07 11:59

At some point GUI was reworked, possibly more such lambdas were introduced.
(0005359)
SXX (administrator)
2015-01-07 12:06

Though I'm checked source code and it's looks like there no other dangerous lambdas like this one. As far as I understand it's should be safe to use non-local variables by reference in lambdas, but would be great if someone more experienced can check exist usages.

Will send pull request once check everything work as expected.
(0005363)
SXX (administrator)
2015-01-07 15:48

So I'm not completely sure what possible caused crash, so I'm decide mark this one as related to this one as related to 0001991 and not as duplicate. Though I suppose Android may be more sensitive to such corruption.

Anyway this one should be fixed in git now:
https://github.com/vcmi/vcmi/commit/af8b030810472770dfeb865a58d54e6660f763c5 [^]

- Issue History
Date Modified Username Field Change
2014-11-11 11:41 Sebt New Issue
2014-11-11 11:41 Sebt Status new => assigned
2014-11-11 11:41 Sebt Assigned To => Warmonger
2014-11-17 11:15 Noui Note Added: 0005118
2015-01-07 11:11 SXX Relationship added has duplicate 0001991
2015-01-07 11:13 SXX Note Added: 0005356
2015-01-07 11:14 SXX Assigned To Warmonger => SXX
2015-01-07 11:50 SXX Note Added: 0005357
2015-01-07 11:59 Warmonger Note Added: 0005358
2015-01-07 12:06 SXX Note Added: 0005359
2015-01-07 15:15 SXX Relationship added related to 0001899
2015-01-07 15:41 SXX Relationship replaced related to 0001991
2015-01-07 15:48 SXX Note Added: 0005363
2015-01-07 15:48 SXX Status assigned => resolved
2015-01-07 15:48 SXX Fixed in Version => 0.97c
2015-01-07 15:48 SXX Resolution open => fixed
2016-01-17 12:35 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean