MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001899VCMIMechanics - Objectspublic2014-09-26 10:242015-04-11 18:07
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.96b 
Target VersionFixed in Version0.97c 
Summary0001899: in this map when I visit the hill fort - crash
Descriptionjust go to - hill fort
TagsNo tags attached.
Attached Files? file icon Revenge 113.h3m [^] (245,211 bytes) 2014-09-26 10:24
txt file icon VCMI_Client_log.txt [^] (2,515,261 bytes) 2014-09-26 10:25
txt file icon VCMI_Server_log.txt [^] (2,373,009 bytes) 2014-09-26 10:25

- Relationships
has duplicate 0001935closedSXX Hill fort crash 
has duplicate 0002021closedSXX Crash while visiting Hill Fort 
related to 0001945closedSXX Crash when learning skill from University or Magic Univercity 
related to 0001991closedSXX Conflux error 

-  Notes
(0004987)
Povelitel (updater)
2014-09-26 10:24

0.96b
(0005037)
Warmonger (administrator)
2014-10-29 17:51
edited on: 2014-10-29 18:07

Game crashes when rendering first free slot, not sure why. Probably issue with block() function.

(0005117)
Noui (reporter)
2014-11-17 11:12
edited on: 2014-11-17 11:19

I can confirm that it doesn't crash as early when the visiting hero doesn't have any free army slots. However, the game does crash when I try to upgrade creatures.

Edit: The game doesn't crash if you upgrade your creatures using the "upgrade all" button, but it does crash if you try to upgrade one specific creature.

(0005349)
SXX (administrator)
2015-01-06 16:25

If no one else doing it at moment I'll start to investigate/fix this one.
So far I'm find out that "upgrade all" button work properly.
(0005350)
SXX (administrator)
2015-01-06 17:10

So problems found that I see after some testing:
1 - Most likely crash with empty slots occur because attempt to "block" non-exist button.
2 - If you attempt to upgrade one unit there is crash (assert) in makeDeal as it's get garbage instead of slot id. Likely occur due to bad code at /client/windows/GUIClasses.cpp:1396
3 - IDs for single unit upgrade also may become messed up a bit. E.g unit in previous slot upgraded instead of choosen one.
(0005351)
SXX (administrator)
2015-01-06 17:18

2 - So it's just invalid capture for lambda here: "&" (grab reference) instead of needed "=":
[&]{ makeDeal(SlotID(i)) };

It's grab reference for i in loop which is obviously become garbade by the time it's called. :-)
(0005353)
Warmonger (administrator)
2015-01-07 08:52

Did that work? I think that's first thing I tried, but with no sucess at that time.
(0005354)
SXX (administrator)
2015-01-07 10:14
edited on: 2015-01-07 10:31

Yeah of course, but there also needed fix crash that occur on button state change. E.g by default game is trying to set state to -1 for empty slots as result there no image for button found and button remain disabled. And code attempt to "block" it cause client crash.

(0005355)
SXX (administrator)
2015-01-07 10:22

So here is pull request:
https://github.com/vcmi/vcmi/pull/74 [^]
(0005360)
SXX (administrator)
2015-01-07 15:11

Should be now fixed in git:
https://github.com/vcmi/vcmi/commit/3466457d69d718f1d1b99a63864474911d9a6f09 [^]

- Issue History
Date Modified Username Field Change
2014-09-26 10:24 Povelitel New Issue
2014-09-26 10:24 Povelitel Status new => assigned
2014-09-26 10:24 Povelitel Assigned To => Ivan
2014-09-26 10:24 Povelitel File Added: Revenge 113.h3m
2014-09-26 10:24 Povelitel Note Added: 0004987
2014-09-26 10:25 Povelitel File Added: VCMI_Client_log.txt
2014-09-26 10:25 Povelitel File Added: VCMI_Server_log.txt
2014-09-26 15:49 Warmonger Product Version 0.96 => 0.96b
2014-10-29 17:51 Warmonger Note Added: 0005037
2014-10-29 18:07 Warmonger Note Edited: 0005037 View Revisions
2014-11-10 08:11 Warmonger Relationship added related to 0001937
2014-11-10 08:12 Warmonger Relationship deleted related to 0001937
2014-11-10 08:12 Warmonger Relationship added related to 0001935
2014-11-17 11:12 Noui Note Added: 0005117
2014-11-17 11:19 Noui Note Edited: 0005117 View Revisions
2015-01-02 15:30 Warmonger Relationship added has duplicate 0002021
2015-01-06 16:25 SXX Note Added: 0005349
2015-01-06 17:10 SXX Note Added: 0005350
2015-01-06 17:10 SXX Assigned To Ivan => SXX
2015-01-06 17:18 SXX Note Added: 0005351
2015-01-07 08:52 Warmonger Note Added: 0005353
2015-01-07 10:14 SXX Note Added: 0005354
2015-01-07 10:22 SXX Note Edited: 0005354 View Revisions
2015-01-07 10:22 SXX Note Added: 0005355
2015-01-07 10:31 SXX Note Edited: 0005354 View Revisions
2015-01-07 15:11 SXX Note Added: 0005360
2015-01-07 15:11 SXX Status assigned => resolved
2015-01-07 15:11 SXX Fixed in Version => 0.97c
2015-01-07 15:11 SXX Resolution open => fixed
2015-01-07 15:14 SXX Relationship replaced has duplicate 0001935
2015-01-07 15:15 SXX Relationship added related to 0001945
2015-01-07 15:48 SXX Relationship added related to 0001991
2015-04-11 18:07 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean