MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002083VCMIMechanics - Objectspublic2015-02-14 19:222015-12-25 08:19
ReporterKantor 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.97b 
Target VersionFixed in Version0.98f 
Summary0002083: Stables bonus is always reset at the beginning of 2nd day of new week
DescriptionStables (and probably other alike objects, not sure here) bonus is always reset at the beginning of 2nd day of new week, but should disappear at first day of new week.
TagsNo tags attached.
Attached Files

- Relationships
related to 0002356assignedSXX New turn handling need refactoring 

-  Notes
(0006221)
SXX (administrator)
2015-12-24 22:56

Fixed:
https://github.com/vcmi/vcmi/commit/66e6f15e671e1d5b9ed6b893632230fab619710c [^]
(0006223)
SXX (administrator)
2015-12-24 23:16
edited on: 2015-12-24 23:20

Oops, right reason but wrong fix. Probably I must get some sleep.

(0006224)
SXX (administrator)
2015-12-25 08:19

Ok here we go:
https://github.com/vcmi/vcmi/commit/6985e96f0d28118315d89f6fddf826e5d210c2ba [^]

This must fix all possible issues with hero because TurnInfo is designed to work out such situations when we want to check bonuses for certain day. Though if we eventually have player-wide bonuses from map objects we really need to rework all this code.

- Issue History
Date Modified Username Field Change
2015-02-14 19:22 Kantor New Issue
2015-02-14 19:27 Kantor Summary Stables bonus is always reset at the beginning of 2nd day => Stables bonus is always reset at the beginning of 2nd day of new week
2015-02-15 04:06 SXX Relationship added related to 0001989
2015-12-24 22:56 SXX Note Added: 0006221
2015-12-24 22:56 SXX Status new => resolved
2015-12-24 22:56 SXX Fixed in Version => 0.98f
2015-12-24 22:56 SXX Resolution open => fixed
2015-12-24 22:56 SXX Assigned To => SXX
2015-12-24 22:56 SXX Relationship deleted related to 0001989
2015-12-24 23:16 SXX Note Added: 0006223
2015-12-24 23:16 SXX Status resolved => assigned
2015-12-24 23:20 SXX Note Edited: 0006223 View Revisions
2015-12-25 08:17 SXX Relationship added related to 0002356
2015-12-25 08:19 SXX Note Added: 0006224
2015-12-25 08:19 SXX Status assigned => resolved

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean