MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002986VCMIRandom Map Generatorpublic2018-08-02 21:112018-08-02 21:11
Reportertukkek 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformLinuxOSDebianOS VersionBuster (testing)
Product Version0.99 
Target VersionFixed in Version 
Summary0002986: Random Map Generators don't work out-of-the-box (fix included)
DescriptionInstalling the game from Debian repositories results in RMG showing a message similar to "cannot create a random map with these parameters" regardless of what parameters are set. Updating the essential game files from the launcher also doesn't fix it, even after the update is completed.

I believe there are no RMG templates provided with the vcmi "essential" mod that comes with the Debian package (or the updated version from the repository).
Steps To ReproduceTo fix the problem I installed the essential files from the following link and now RMGs seem to be working fine after manually enabling all of them (although I haven't tested anything extensively) https://wiki.vcmi.eu/Mod_list#Utilities [^]

I have also removed the vcmi "essential files" mod folder from my system folder and put the new vcmi files into my user configuration folder instead (~/.local/share/vcmi/Mods). This was a prerequisite for trying to upgrade the package from the launcher (even though that didn't fix RMG).
Additional InformationI'm not realizing that I don't know whether RMGs are supposed to be working out of the box at all for 0.99 - however, since the wiki states RMG is functional, I suppose it's OK to expect it to be working with the latest release of the game.

Also of note is that the "essential files" mod that comes with the 0.99 Debian package shows itself to be 0.98 in the launcher. After refreshing the repository, it says it is outdated but still shows as 0.98 after the update (and doesn't fix RMG regardless).

Would updating the "essential files" mod in the repository to the 1.0 version (linked above) fix this or be possible at all? Also of note is that the linked version shows itself as 0.96 in the launcher for some files and 0.0 or 0.99 for others.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2018-08-02 21:11 tukkek New Issue

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean