MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002624VCMIAI - Adventure Mappublic2016-11-29 18:252018-02-28 18:08
ReporterPovelitel 
Assigned ToWarmonger 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version0.99 
Target VersionFixed in Version0.next 
Summary0002624: Crash turn AI
Descriptionsecond save continue1

_CSTD memmove(_Dest_ch, _First_ch, _Count);


> [Внедренный фрейм] VCMI_lib.dll!std::_Copy_memmove(ConstTransitivePtr<CGDwelling> *)Строка 2380 C++ Символы загружены.
     [Внедренный фрейм] VCMI_lib.dll!std::_Move_unchecked1(ConstTransitivePtr<CGDwelling> *)Строка 2709 C++ Символы загружены.
     [Внедренный фрейм] VCMI_lib.dll!std::_Move_unchecked(ConstTransitivePtr<CGDwelling> * _First, ConstTransitivePtr<CGDwelling> *)Строка 2718 C++ Символы загружены.
     [Внедренный фрейм] VCMI_lib.dll!std::vector<ConstTransitivePtr<CGDwelling>,std::allocator<ConstTransitivePtr<CGDwelling> > >::erase(std::_Vector_const_iterator<std::_Vector_val<std::_Simple_types<ConstTransitivePtr<CGDwelling> > > >)Строка 1618 C++ Символы загружены.
     VCMI_lib.dll!CGDwelling::setPropertyDer(unsigned char what, unsigned int val)Строка 166 C++ Символы загружены.
     VCMI_lib.dll!CGObjectInstance::setProperty(unsigned char what, unsigned int val)Строка 223 C++ Символы загружены.
     VCMI_lib.dll!SetObjectProperty::applyGs(CGameState * gs)Строка 1183 C++ Символы загружены.
     VCMI_lib.dll!CApplyOnGS<SetObjectProperty>::applyOnGS(CGameState * gs, void * pack)Строка 63 C++ Символы загружены.
     VCMI_lib.dll!CGameState::apply(CPack * pack)Строка 1958 C++ Символы загружены.
     VCMI_client.exe!CClient::handlePack(CPack * pack)Строка 686 C++ Символы загружены.
     VCMI_client.exe!CClient::run()Строка 190 C++ Символы загружены.
TagsNo tags attached.
Attached Files7z file icon purpure_crash.7z [^] (777,683 bytes) 2016-11-29 18:25
rar file icon Continue1.rar [^] (1,979,571 bytes) 2018-01-15 12:13

- Relationships

-  Notes
(0006924)
SXX (administrator)
2016-11-29 19:10

Workarounded this one:
https://github.com/vcmi/vcmi/commit/fd3992ddc9cb9ee01586edbe59d8a82548a5c909 [^]

Looks like for some reason this code was working before, but I don't see any recent changes around. Will try to dig it deeply later on.
(0006925)
Warmonger (administrator)
2016-11-29 20:59
edited on: 2016-11-29 21:00

Strangely enough I can't open this save, in fact there was an error message at 7z extraction and save is 0 KB :?

(0006926)
Warmonger (administrator)
2016-11-29 21:09

Hopefully fixed in https://github.com/vcmi/vcmi/commit/eaf14f6429f3d850f029c8942798b1e5b0efa80c [^]
(0007366)
Povelitel (updater)
2018-01-15 12:13
edited on: 2018-01-15 12:14

I took this save and continue to play.
build VCMI-branch-develop-e90fcea

And again happen crash.

The same bag or not I don't know


Just press end turn

(0007367)
Dydzio (developer)
2018-01-15 12:18

I think we should reopen this one for now...

- Issue History
Date Modified Username Field Change
2016-11-29 18:25 Povelitel New Issue
2016-11-29 18:25 Povelitel Status new => assigned
2016-11-29 18:25 Povelitel Assigned To => SXX
2016-11-29 18:25 Povelitel File Added: purpure_crash.7z
2016-11-29 19:10 SXX Note Added: 0006924
2016-11-29 20:13 Warmonger Assigned To SXX => Warmonger
2016-11-29 20:59 Warmonger Note Added: 0006925
2016-11-29 21:00 Warmonger Note Edited: 0006925 View Revisions
2016-11-29 21:09 Warmonger Note Added: 0006926
2016-11-29 21:09 Warmonger Status assigned => resolved
2016-11-29 21:09 Warmonger Fixed in Version => 0.next
2016-11-29 21:09 Warmonger Resolution open => fixed
2018-01-15 12:13 Povelitel Note Added: 0007366
2018-01-15 12:13 Povelitel File Added: Continue1.rar
2018-01-15 12:14 Povelitel Note Edited: 0007366 View Revisions
2018-01-15 12:18 Dydzio Note Added: 0007367
2018-01-15 12:18 Dydzio Status resolved => assigned
2018-02-28 18:08 Povelitel Priority high => normal
2018-02-28 18:08 Povelitel Resolution fixed => reopened
2018-02-28 18:08 Povelitel Description Updated View Revisions

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean