MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002599VCMIAI - Battlespublic2016-11-11 18:152016-12-11 21:32
ReporterPovelitel 
Assigned ToDydzio 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.99 
Target VersionFixed in Version0.next 
Summary0002599: Crash when I use R click on enemy hero in battle
DescriptionВражеский герой нападает на меня, я кликаю на него правой кнопкой мыши - происходит вылет игры.
Steps To ReproduceНажать конец хода
TagsNo tags attached.
Attached Files7z file icon r-click.7z [^] (388,477 bytes) 2016-11-11 18:15

- Relationships

-  Notes
(0006930)
Dydzio (developer)
2016-12-05 13:52

Fixed in: https://github.com/vcmi/vcmi/pull/261 [^]
(0006931)
Povelitel (updater)
2016-12-08 07:42

ih this save still crash, it's normal?
(0006932)
Dydzio (developer)
2016-12-08 10:51

I'll check later
(0006934)
Dydzio (developer)
2016-12-10 10:38

Still crashable because of
"ERROR_RET_VAL_IF(!isVisible(h->getPosition(false)), "That hero is not visible!", false);"

when getting enemy hero info in battle while he attacks. Probably above code uses enemy hero position before making a move.
(0006935)
SXX (administrator)
2016-12-11 18:16

So it's now fixed:
https://github.com/vcmi/vcmi/pull/262 [^]

Problem caused by fact that enemy hero attacked from teleporter entry that was within fog of war. Same would happen if you attack enemy on other side of teleporter.

- Issue History
Date Modified Username Field Change
2016-11-11 18:15 Povelitel New Issue
2016-11-11 18:15 Povelitel Status new => assigned
2016-11-11 18:15 Povelitel Assigned To => SXX
2016-11-11 18:15 Povelitel File Added: r-click.7z
2016-12-05 13:52 Dydzio Note Added: 0006930
2016-12-05 13:52 Dydzio Status assigned => resolved
2016-12-05 13:52 Dydzio Fixed in Version => 0.next
2016-12-05 13:52 Dydzio Resolution open => fixed
2016-12-05 13:52 Dydzio Assigned To SXX => Dydzio
2016-12-08 07:42 Povelitel Note Added: 0006931
2016-12-08 10:51 Dydzio Note Added: 0006932
2016-12-10 10:38 Dydzio Note Added: 0006934
2016-12-10 10:38 Dydzio Status resolved => assigned
2016-12-11 18:16 SXX Note Added: 0006935
2016-12-11 18:16 SXX Status assigned => resolved
2016-12-11 21:32 SXX Relationship added related to 0002631
2016-12-11 21:32 SXX Relationship deleted related to 0002631

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean