MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002321VCMIGUI - Town screenpublic2015-11-01 01:242016-10-15 06:29
ReporterSXX 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product Version0.98d 
Target VersionFixed in Version0.99 
Summary0002321: If any building dependency is disabled then building should be considered disabled too
DescriptionCurrently in VCMI on Town screen when there is building that require another building (e.g City Hall require Tovern) is disabled it's still shows in red color.

H3 behaviour is different:
 - If any of dependencies are disabled building shown as disabled too.
 - H3 also don't show dependencies of disabled building, but I think we shouldn't reproduce this behaviour.

In practice this doesn't change anything except building have gray border instead of red.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001734resolvedSXX City Hall/Capitol can be built if Tavern is unavailable for the town 

-  Notes
(0006637)
ch (reporter)
2016-09-10 17:42

I prepared patch for this issue: https://github.com/Chocimier/vcmi/commit/4000346 [^]
Do anything need to be changed before merging?
(0006638)
AVS (administrator)
2016-09-10 17:59

Thank you for patch. Make pull request please.
(0006671)
SXX (administrator)
2016-09-13 21:46

Fixed by @Chocimier in PR211:
https://github.com/vcmi/vcmi/pull/211 [^]
(0006828)
AVS (administrator)
2016-10-14 20:50

Features of https://github.com/vcmi/vcmi/pull/211 [^] were actually disabled due to regression.
(0006829)
AVS (administrator)
2016-10-15 01:45

Less dirty fix was applied. More tests needed.
(0006830)
misiokles (reporter)
2016-10-15 06:27

@Chocimier.
Till 0.98g version there was possibility to make mod with alternate buildings and creatures like in Heroes4. Your fix was fine to get town screen closer to vanilla H3 but somehow broke possibility to get alt buildings.
There's work-in-progress mod that will bring one alternate building in every standard h3 town. Alpha version worked in 0.98g, but causes crashes when trying to enter town hall after your fix.
Here's placeholder version to test:
http://www86.zippyshare.com/v/D6B17vnA/file.html [^]
1. Enable mod.
2. Launch any map with Twer as starting town.

3. Enter town hall - now game crashes

But earlier was next:

4. You can build Cloud Temple or Factory as 7 tier dwelling.
5. When you choose Cloud Temple/Factory then Factory/Cloud Temple building is blocked.

I hope your fix can be rewrited and allow to built alt buildings.
(0006831)
misiokles (reporter)
2016-10-15 06:29

Little spoiler of Fortress alt build:
http://www.hota.acidcave.net/sphinx/160522223050cytadela.png [^]

- Issue History
Date Modified Username Field Change
2015-11-01 01:24 SXX New Issue
2015-11-01 01:24 SXX Status new => assigned
2015-11-01 01:24 SXX Assigned To => Ivan
2015-11-01 01:24 SXX Relationship added related to 0001734
2015-11-01 01:35 SXX Summary If any building dependencies are disabled it's should be considered disabled too => If any building dependency is disabled then should be considered disabled too
2015-11-01 01:36 SXX Description Updated View Revisions
2015-11-02 21:46 SXX Summary If any building dependency is disabled then should be considered disabled too => If any building dependency is disabled then building should be considered disabled too
2016-09-10 17:42 ch Note Added: 0006637
2016-09-10 17:59 AVS Note Added: 0006638
2016-09-13 21:46 SXX Note Added: 0006671
2016-09-13 21:46 SXX Status assigned => resolved
2016-09-13 21:46 SXX Fixed in Version => 0.99
2016-09-13 21:46 SXX Resolution open => fixed
2016-09-13 21:46 SXX Assigned To Ivan =>
2016-10-14 20:50 AVS Note Added: 0006828
2016-10-14 20:50 AVS Status resolved => feedback
2016-10-14 20:50 AVS Resolution fixed => reopened
2016-10-15 01:45 AVS Note Added: 0006829
2016-10-15 06:27 misiokles Note Added: 0006830
2016-10-15 06:29 misiokles Note Added: 0006831

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean