MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002316VCMIMechanics - Otherpublic2015-10-24 23:342016-11-11 07:43
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version0.98d 
Target VersionFixed in Version0.99 
Summary0002316: Unique: Crash during AI turn (Bonus::DISGUISED check)
DescriptionClient crash, server crash
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (1,521,880 bytes) 2015-10-24 23:34
txt file icon VCMI_Client_log.txt [^] (2,261,506 bytes) 2015-10-24 23:34
txt file icon VCMI_Server_log.txt [^] (994,927 bytes) 2015-10-24 23:34 [Show Content]

- Relationships
related to 0002314resolvedAVS Crashes related to bonus system in deserializationFix 

-  Notes
(0006004)
Warmonger (administrator)
2015-10-25 07:50

Can't load :(
(0006019)
Povelitel (updater)
2015-10-25 11:19

The same is true of the 2308 saves as I loaded ...
(0006023)
Warmonger (administrator)
2015-10-25 18:01

OK works now.
(0006024)
Warmonger (administrator)
2015-10-25 18:05

Crash is related to bugged Bonus at DISGUISE check:

int disguiseLevel = h->valOfBonuses(Selector::typeSubtype(Bonus::DISGUISED, 0));

in CGameInfoCallback.cpp, line 267

Debugger actually points at

int decision = b->limiter ? b->limiter->limit(context) : ILimiter::ACCEPT;

in HeroBonus.cpp, line 1042

So probably it's not AI bug.
(0006178)
SXX (administrator)
2015-12-14 06:05
edited on: 2015-12-14 06:06

BTW @AVS you may want to look at this one.
It's the only bonus-related crash I managed to get in noncopyableBonusSystemNode branch:
https://github.com/vcmi/vcmi/pull/148 [^]

Though I have no idea if it's related or not. Anyway it's related to spell implementation at least. :-)

(0006235)
SXX (administrator)
2015-12-25 12:22

So basically this is the only crash that not really fixed by noncopyableBonusSystemNode.
All other are fixed by branch.
(0006616)
SXX (administrator)
2016-09-04 08:20

I'll pretend this one was still related to 0002314.
So not reproducible anymore.

- Issue History
Date Modified Username Field Change
2015-10-24 23:34 Povelitel New Issue
2015-10-24 23:34 Povelitel Status new => assigned
2015-10-24 23:34 Povelitel Assigned To => Warmonger
2015-10-24 23:34 Povelitel File Added: Saves.rar
2015-10-24 23:34 Povelitel File Added: VCMI_Client_log.txt
2015-10-24 23:34 Povelitel File Added: VCMI_Server_log.txt
2015-10-25 07:50 Warmonger Note Added: 0006004
2015-10-25 11:19 Povelitel Note Added: 0006019
2015-10-25 17:05 Povelitel Relationship added related to 0002318
2015-10-25 18:01 Warmonger Note Added: 0006023
2015-10-25 18:05 Warmonger Note Added: 0006024
2015-10-25 18:06 Warmonger Assigned To Warmonger =>
2015-10-25 18:06 Warmonger Status assigned => new
2015-10-25 18:06 Warmonger Category AI - Adventure Map => Mechanics - Other
2015-10-25 18:13 Warmonger Relationship added related to 0002315
2015-12-11 20:57 SXX Relationship added related to 0002314
2015-12-14 06:04 SXX Relationship deleted related to 0002314
2015-12-14 06:04 SXX Assigned To => AVS
2015-12-14 06:04 SXX Status new => assigned
2015-12-14 06:05 SXX Note Added: 0006178
2015-12-14 06:06 SXX Note Edited: 0006178 View Revisions
2015-12-25 12:15 SXX Relationship deleted related to 0002315
2015-12-25 12:16 SXX Summary Crash during AI turn => Crash during AI turn (Bonus::DISGUISED check)
2015-12-25 12:20 SXX Relationship deleted related to 0002318
2015-12-25 12:22 SXX Summary Crash during AI turn (Bonus::DISGUISED check) => Unique: Crash during AI turn (Bonus::DISGUISED check)
2015-12-25 12:22 SXX Note Added: 0006235
2016-09-04 08:19 SXX Relationship added related to 0002314
2016-09-04 08:20 SXX Note Added: 0006616
2016-09-04 08:20 SXX Status assigned => resolved
2016-09-04 08:20 SXX Fixed in Version => 0.99
2016-09-04 08:20 SXX Resolution open => unable to reproduce
2016-09-04 08:20 SXX Assigned To AVS => SXX
2016-11-11 07:43 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean