MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002301VCMIAI - Adventure Mappublic2015-10-14 11:092016-11-11 07:34
ReporterPovelitel 
Assigned ToAVS 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64OSWindowsOS VersionXP sp2
Product Version0.98d 
Target VersionFixed in Version0.99 
Summary0002301: Freeze turn AI
DescriptionOrange player

(It seemed to me this invisible tile)
Additional Informationclient

2015-Oct-14 14:07:46.718750 TRACE network [658] - received server message of type struct PackageApplied, data: {CPack: type '94'}
2015-Oct-14 14:07:46.718750 TRACE network [658] - Made first apply on cl
2015-Oct-14 14:07:46.718750 TRACE network [658] - Applied on gs
2015-Oct-14 14:07:46.718750 TRACE ai [658] - Entering void __thiscall VCAI::requestRealized(struct PackageApplied *).
2015-Oct-14 14:07:46.718750 TRACE ai [658] - Leaving void __thiscall VCAI::requestRealized(struct PackageApplied *).
2015-Oct-14 14:07:46.718750 TRACE network [658] - Made second apply on cl
2015-Oct-14 14:07:46.718750 TRACE network [658] - Listening...
2015-Oct-14 14:07:46.718750 INFO global [538] - Player 3 ended turn
2015-Oct-14 14:07:46.718750 TRACE network [658] - received server message of type struct YourTurn, data: {CPack: type '100'}
2015-Oct-14 14:07:46.718750 TRACE network [658] - Made first apply on cl
2015-Oct-14 14:07:46.718750 TRACE network [658] - Applied on gs
2015-Oct-14 14:07:46.750000 TRACE ai [658] - Entering void __thiscall VCAI::yourTurn(void).
2015-Oct-14 14:07:46.750000 TRACE ai [658] - Leaving void __thiscall VCAI::yourTurn(void).
2015-Oct-14 14:07:46.750000 TRACE network [658] - Made second apply on cl
2015-Oct-14 14:07:46.750000 TRACE network [658] - Listening...
2015-Oct-14 14:07:46.750000 INFO global [67c] - Player 4 starting turn
2015-Oct-14 14:07:46.750000 DEBUG ai [67c] - Striving to goal of type WIN
2015-Oct-14 14:07:46.750000 DEBUG ai [67c] - Considering goal WIN
2015-Oct-14 14:07:46.750000 DEBUG ai [67c] - Considering goal CONQUER
2015-Oct-14 14:07:46.859375 DEBUG ai [67c] - Considering goal EXPLORE
2015-Oct-14 14:07:46.875000 TRACE ai [67c] - Time of where to explore was 16 ms.
2015-Oct-14 14:07:46.906250 TRACE ai [67c] - Time of where to explore was 16 ms.
2015-Oct-14 14:07:46.921875 TRACE ai [67c] - Time of where to explore was 16 ms.
2015-Oct-14 14:07:47.015625 TRACE ai [67c] - Time of where to explore was 93 ms.
2015-Oct-14 14:07:47.109375 TRACE ai [67c] - Time of where to explore was 94 ms.
2015-Oct-14 14:07:47.203125 TRACE ai [67c] - Time of where to explore was 94 ms.
2015-Oct-14 14:07:47.218750 TRACE ai [67c] - Time of where to explore was 15 ms.
2015-Oct-14 14:07:47.234375 TRACE ai [67c] - Time of where to explore was 16 ms.
2015-Oct-14 14:07:47.250000 DEBUG ai [67c] - Choosing abstract goal EXPLORE (Azagthoth)
2015-Oct-14 14:07:47.250000 DEBUG ai [67c] - Striving to goal of type EXPLORE (Azagthoth)
2015-Oct-14 14:07:47.250000 DEBUG ai [67c] - Considering goal EXPLORE (Azagthoth)
2015-Oct-14 14:07:47.343750 TRACE ai [67c] - Time of where to explore was 93 ms.
2015-Oct-14 14:07:47.343750 DEBUG ai [67c] - Considering goal VISIT TILE (115 44 1) (Azagthoth)
2015-Oct-14 14:07:47.359375 DEBUG ai [67c] - Trying to realize VISIT TILE (115 44 1) (Azagthoth) (value 3.999)
2015-Oct-14 14:07:47.359375 DEBUG ai [67c] - Moving hero Azagthoth to tile 115 44 1
2015-Oct-14 14:07:47.359375 TRACE network [67c] - Sending a request "struct MoveHero". It'll have an ID=261.
2015-Oct-14 14:07:47.359375 TRACE network [67c] - Sending to server a pack of type struct MoveHero
2015-Oct-14 14:07:47.359375 TRACE global [67c] - We'll wait till request 261 is answered.


server

2015-Oct-14 14:07:46.703125 TRACE global [930] - Player 3 wants to move hero 5056 from 84 88 0 to 84 89 0
2015-Oct-14 14:07:46.703125 TRACE global [930] - Entering bool __thiscall CGameHandler::moveHero::<lambda_522697fc3266f702b517296dbc534735>::operator ()(enum TryMoveHero::EResult,enum CGameHandler::EGuardLook,enum CGameHandler::EVisitDest,enum CGameHandler::ELEaveTile) const: Hero PРІgal starts movement from 84 88 0 to 84 89 0.
2015-Oct-14 14:07:46.703125 TRACE global [930] - Created a new query with id 334
2015-Oct-14 14:07:46.703125 TRACE global [930] - Entering void __thiscall Queries::addQuery(class PlayerColor,class std::shared_ptr<class CQuery>): player='3', query='[02,850,274] A query of type class CHeroMovementQuery and qid=334 affecting players (3)'.
2015-Oct-14 14:07:46.703125 TRACE global [930] - Sending to all clients a package of type struct PlayerBlocked
2015-Oct-14 14:07:46.703125 TRACE global [930] - Leaving void __thiscall Queries::addQuery(class PlayerColor,class std::shared_ptr<class CQuery>).
2015-Oct-14 14:07:46.703125 TRACE global [930] - Sending to all clients a package of type struct TryMoveHero
2015-Oct-14 14:07:46.703125 TRACE global [930] - Entering void __thiscall Queries::popIfTop(class std::shared_ptr<class CQuery>): query='[02,850,274] A query of type class CHeroMovementQuery and qid=334 affecting players (3)'.
2015-Oct-14 14:07:46.703125 TRACE global [930] - Entering void __thiscall Queries::popQuery(class PlayerColor,class std::shared_ptr<class CQuery>): player='3', query='[02,850,274] A query of type class CHeroMovementQuery and qid=334 affecting players (3)'.
2015-Oct-14 14:07:46.703125 TRACE global [930] - Sending to all clients a package of type struct PlayerBlocked
2015-Oct-14 14:07:46.703125 TRACE global [930] - Leaving void __thiscall Queries::popQuery(class PlayerColor,class std::shared_ptr<class CQuery>).
2015-Oct-14 14:07:46.703125 TRACE global [930] - Leaving void __thiscall Queries::popIfTop(class std::shared_ptr<class CQuery>).
2015-Oct-14 14:07:46.703125 TRACE global [930] - Hero PРІgal ends movement
2015-Oct-14 14:07:46.703125 TRACE global [930] - Destructed the query with id 334
2015-Oct-14 14:07:46.703125 TRACE global [930] - Leaving bool __thiscall CGameHandler::moveHero::<lambda_522697fc3266f702b517296dbc534735>::operator ()(enum TryMoveHero::EResult,enum CGameHandler::EGuardLook,enum CGameHandler::EVisitDest,enum CGameHandler::ELEaveTile) const.
2015-Oct-14 14:07:46.703125 TRACE global [930] - Message successfully applied (result=1)!
2015-Oct-14 14:07:46.718750 TRACE global [930] - Received client message (request 260 by player ) of type with ID=230 (struct EndTurn).

2015-Oct-14 14:07:46.718750 TRACE global [930] - Message successfully applied (result=1)!
2015-Oct-14 14:07:46.718750 TRACE global [aec] - Sending to all clients a package of type struct YourTurn
2015-Oct-14 14:07:47.359375 TRACE global [930] - Received client message (request 261 by player ) of type with ID=232 (struct MoveHero).

2015-Oct-14 14:07:47.359375 TRACE global [930] - Player 4 wants to move hero 6527 from 117 44 1 to 116 44 1
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (1,269,925 bytes) 2015-10-14 11:09

- Relationships
duplicate of 0002314resolvedAVS Crashes related to bonus system in deserializationFix 

-  Notes
(0006028)
Warmonger (administrator)
2015-10-25 18:27

Can't tell about freeze, it just crashed.

Duplicate of 0002318 - crash at FLYING_MOVEMENT Bonus.
(0006611)
SXX (administrator)
2016-09-04 08:13

Fixed by PR202. For more details or comments please check 0002314

- Issue History
Date Modified Username Field Change
2015-10-14 11:09 Povelitel New Issue
2015-10-14 11:09 Povelitel Status new => assigned
2015-10-14 11:09 Povelitel Assigned To => Warmonger
2015-10-14 11:09 Povelitel File Added: Saves.rar
2015-10-25 18:27 Warmonger Note Added: 0006028
2015-10-25 18:27 Warmonger Relationship added duplicate of 0002318
2015-10-25 18:28 Warmonger Assigned To Warmonger =>
2015-10-25 18:28 Warmonger Status assigned => new
2015-12-25 12:14 SXX Relationship added duplicate of 0002314
2015-12-25 12:20 SXX Relationship deleted 0002318
2016-09-04 08:13 SXX Note Added: 0006611
2016-09-04 08:13 SXX Status new => resolved
2016-09-04 08:13 SXX Fixed in Version => 0.99
2016-09-04 08:13 SXX Resolution open => fixed
2016-09-04 08:13 SXX Assigned To => AVS
2016-11-11 07:34 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean