MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002287VCMIAI - Adventure Mappublic2015-10-06 14:432016-04-07 13:41
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.98d 
Target VersionFixed in Version0.98f 
Summary0002287: Heroes just closed when turn AI
DescriptionJust press end turn
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (883,051 bytes) 2015-10-06 14:43

- Relationships
duplicate of 0002345resolvedSXX Fog of War changing objects may completely cover heroes/towns 

-  Notes
(0005932)
SXX (administrator)
2015-10-06 18:30
edited on: 2015-10-06 18:32

It's don't crash for me with latest develop git.

UPD: Turn just take really long time under debugger, but it's crashed eventually without gdb:
vcmiclient: /home/i/VCMI/mine/vcmi/AI/VCAI/VCAI.cpp:1849: VCAI::moveHeroToTile(int3, HeroPtr)::__lambda33: 
Assertion `tile' failed.
Aborted (core dumped)


(0005982)
SXX (administrator)
2015-10-24 16:49

This one is for sure not related to 0002311.
(0006027)
Warmonger (administrator)
2015-10-25 18:18

For some reason AI tries to step onto tile it cannot see.
(0006161)
SXX (administrator)
2015-12-09 08:31

Checked this one: cover of darkness map object has covered "Aeris" hero.
So dupe for sure.

- Issue History
Date Modified Username Field Change
2015-10-06 14:43 Povelitel New Issue
2015-10-06 14:43 Povelitel Status new => assigned
2015-10-06 14:43 Povelitel Assigned To => Warmonger
2015-10-06 14:43 Povelitel File Added: Saves.rar
2015-10-06 18:30 SXX Note Added: 0005932
2015-10-06 18:32 SXX Note Edited: 0005932 View Revisions
2015-10-20 14:31 Povelitel Relationship added related to 0002311
2015-10-24 16:48 SXX Relationship deleted related to 0002311
2015-10-24 16:49 SXX Note Added: 0005982
2015-10-25 18:18 Warmonger Note Added: 0006027
2015-10-25 18:18 Warmonger Status assigned => confirmed
2015-10-25 18:34 Warmonger Relationship added has duplicate 0002134
2015-12-09 08:31 SXX Note Added: 0006161
2015-12-09 08:31 SXX Relationship added duplicate of 0002345
2015-12-09 08:31 SXX Status confirmed => resolved
2015-12-09 08:31 SXX Fixed in Version => 0.98f
2015-12-09 08:31 SXX Resolution open => fixed
2015-12-09 08:31 SXX Assigned To Warmonger => SXX
2015-12-09 08:31 SXX Relationship deleted has duplicate 0002134
2016-04-07 13:41 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean