MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002311VCMIAI - Adventure Mappublic2015-10-20 14:312016-04-07 13:41
ReporterPovelitel 
Assigned ToWarmonger 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64OSWindowsOS VersionXP sp2
Product Version0.98d 
Target VersionFixed in Version0.98e 
Summary0002311: Heroes just closed when turn AI
DescriptionJust press end turn
TagsNo tags attached.
Attached Filesrar file icon QUIT.rar [^] (375,579 bytes) 2015-10-20 14:31
txt file icon VCMI_Client_log.txt [^] (385,611 bytes) 2015-10-20 14:31 [Show Content]
txt file icon VCMI_Server_log.txt [^] (248,242 bytes) 2015-10-20 14:31 [Show Content]

- Relationships
related to 0002072resolvedWarmonger After loading save of last 7 day without town you lose 

-  Notes
(0005963)
SXX (administrator)
2015-10-22 11:32

Can't reproduce, it's don't crash for me.
(0005964)
Povelitel (updater)
2015-10-22 12:21

They don't crash, they just closed. Or you have good work?
(0005965)
SXX (administrator)
2015-10-22 12:38

It's working fine for me on commit 273392752754a8d766cf3b80c02b5b0c49d8f64d which is basically 0.98d release. Basically on this turn Teal player is dying on that turn and game continues.

BTW I may confirm it's does crash on 0.98d Windows build.....
(0005966)
SXX (administrator)
2015-10-22 12:42

Assertion failed: obj, file AIUtility.cpp, line 103
(0005969)
Warmonger (administrator)
2015-10-24 12:34

Confirmed, game crashes after players are supposed to win / lose.
(0005970)
SXX (administrator)
2015-10-24 12:46
edited on: 2015-10-24 12:46

BTW I asked @AVS to check it and it's crashes for him too while he's not using VC++.
Any idea why it's not crash on Linux for me?

(0005972)
Warmonger (administrator)
2015-10-24 13:13

Looks like desync / threading issue, AI player still tries to move heroes around despite he lost.
(0005973)
Warmonger (administrator)
2015-10-24 13:58

It seems that loss condition (no town) is checked for player 6 only after AI has already started turn.
(0005979)
Warmonger (administrator)
2015-10-24 16:22

Fixed in https://github.com/vcmi/vcmi/commit/61692ba168bafa5f08df9bbd7526bf21339b0dcb [^]

- Issue History
Date Modified Username Field Change
2015-10-20 14:31 Povelitel New Issue
2015-10-20 14:31 Povelitel Status new => assigned
2015-10-20 14:31 Povelitel Assigned To => Warmonger
2015-10-20 14:31 Povelitel File Added: QUIT.rar
2015-10-20 14:31 Povelitel File Added: VCMI_Client_log.txt
2015-10-20 14:31 Povelitel File Added: VCMI_Server_log.txt
2015-10-20 14:31 Povelitel Relationship added related to 0002287
2015-10-22 11:32 SXX Note Added: 0005963
2015-10-22 12:21 Povelitel Note Added: 0005964
2015-10-22 12:38 SXX Note Added: 0005965
2015-10-22 12:42 SXX Note Added: 0005966
2015-10-24 12:34 Warmonger Note Added: 0005969
2015-10-24 12:34 Warmonger Status assigned => confirmed
2015-10-24 12:46 SXX Note Added: 0005970
2015-10-24 12:46 SXX Note Edited: 0005970 View Revisions
2015-10-24 13:13 Warmonger Note Added: 0005972
2015-10-24 13:58 Warmonger Note Added: 0005973
2015-10-24 15:38 Warmonger Relationship added related to 0002072
2015-10-24 16:22 Warmonger Note Added: 0005979
2015-10-24 16:22 Warmonger Status confirmed => resolved
2015-10-24 16:22 Warmonger Fixed in Version => 0.98e
2015-10-24 16:22 Warmonger Resolution open => fixed
2015-10-24 16:48 SXX Relationship deleted related to 0002287
2016-04-07 13:41 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean