MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002248VCMIAI - Adventure Mappublic2015-08-31 11:322016-11-11 08:26
ReporterDydzio 
Assigned ToWarmonger 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoft WindowsOSWindows 7OS VersionHome Premium x64
Product Version0.98c 
Target VersionFixed in Version0.98d 
Summary0002248: Client crashes on very complex map on first AI turn
DescriptionWhen playing "The empire of the world II" map, then game client crashes on first turn (null pointer access attempt).
Steps To ReproduceStart the map attached to this report and pass a turn.
Additional InformationThe map tends to crash after few hundreds of turns for some players in original H3 as well, because of its complexity, but there should be no crash on first turn. Looks like AI can not handle situation on map well (no taverns in towns, etc). I attach map, saved game (1st day of the map) and crash logs to the report.
TagsNo tags attached.
Attached Fileszip file icon crash.zip [^] (3,320,169 bytes) 2015-08-31 11:32

- Relationships
related to 0002225closedWarmonger Have crash in 1 day after end turn 

-  Notes
(0005883)
Warmonger (administrator)
2015-10-01 15:28

Fixed in 0.98d, probably duplicate of 0002225.

- Issue History
Date Modified Username Field Change
2015-08-31 11:32 Dydzio New Issue
2015-08-31 11:32 Dydzio Status new => assigned
2015-08-31 11:32 Dydzio Assigned To => Warmonger
2015-08-31 11:32 Dydzio File Added: crash.zip
2015-10-01 15:28 Warmonger Note Added: 0005883
2015-10-01 15:28 Warmonger Status assigned => resolved
2015-10-01 15:28 Warmonger Fixed in Version => 0.98d
2015-10-01 15:28 Warmonger Resolution open => fixed
2015-10-01 15:28 Warmonger Relationship added related to 0002225
2016-11-11 08:26 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean