MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002230VCMILauncherpublic2015-08-16 20:072016-11-11 08:26
ReporterDrake 
Assigned ToAVS 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformWindowsOSWindows 10 HomeOS Versionbuild 10240
Product Version0.98c 
Target VersionFixed in Version0.98d 
Summary0002230: VCMI (0.98c) client crashes when executed
DescriptionEach time I try to run VCMI from the launcher or client executable it crashes with this error--
Disaster happened.
Reason: 0xe06d7363 - UNKNOWN EXCEPTION at 0023:75,2D3,E28
Thread ID: 5600 [5600]
Crash info will be put in VCMI_client.exe_crashinfo.dmp
Steps To ReproduceRun the VCMI client from executable or launcher.
Additional InformationI installed VCMI with a clean installation of Heroes 3 Complete and removed the old VCMI folder in C:\Users\user\Documents\My Games\vcmi.
TagsNo tags attached.
Attached Filestxt file icon VCMI_Client_log.txt [^] (25,216 bytes) 2015-08-16 20:07 [Show Content]
txt file icon VCMI_Launcher_log.txt [^] (4,338 bytes) 2015-08-16 20:08 [Show Content]
zip file icon VCMI_client.exe_crashinfo.dmp.zip [^] (342,168 bytes) 2015-08-16 20:10

- Relationships

-  Notes
(0005776)
Warmonger (administrator)
2015-08-17 04:45

Together with 0002231 it suggests incorrect install or OS error. Did it work at Windows 10 before?
(0005778)
Drake (reporter)
2015-08-17 15:11

0.98b and older actually played before, but now it won't and it gives me this error. Error 0002231 has been there ever since I updated from 0.97x to 0.98x. It's all the same on Windows 10. I'll try it on another computer and see if anything is different.
(0005779)
Drake (reporter)
2015-08-19 00:34

Unfortunately, I get the same issue on other Windows 10 computers. I'm not sure why it is. I just assumed because Heroes 3 Era and HotA works perfectly on it that VCMI would too. However, error 0002231 has been like this on every computer I've had with VCMI (Windows 7 and up). The last thing that the VCMI command window said before the disaster happened was that it found 4 render drivers. Perhaps it has something to do with Windows 10 graphics?
(0005780)
Drake (reporter)
2015-08-19 00:37

Is it safe to install every mod that the VCMI launcher has? I leave out the different language ones. But on all of my VCMI installations, I always have every mod installed and updated. I was told by someone that the mods were all compatible together, so I assumed it was safe.
(0005781)
Warmonger (administrator)
2015-08-19 04:55

Yes it is, that's why the mods are in our Launcher. In general mods can't cause any system problems as they are ony data files - no executables or libraries.
(0005782)
Drake (reporter)
2015-08-20 01:39

Oh. Well, I believe tis problem might have something to do with graphics. Does VCMI require a certain version of OpenGL to run? Ever since the update from Windows 7 to Windows 10, my graphics card driver only has OpenGL 1.1, where it used to 2.1.
(0005783)
AVS (administrator)
2015-08-22 11:27

try direct3d backend

In ... \Documents\My Games\vcmi\config\settings.json add "driver": "direct3d" in "video" section.
(0005784)
Drake (reporter)
2015-08-22 14:15

That's it AVS! It opens perfectly now. I just knew it had something to do with the graphics. Some other Windows 10 users are likely to have this problem if their video card isn't supported like mine lol. Just wish I could get my other games to run on Direct3D Backend like this :P
(0005785)
AVS (administrator)
2015-08-22 14:18

Video driver problem, not a VCMI bug. Also fixable by changing backend to Direct3d.
(0005788)
Drake (reporter)
2015-08-22 14:37

True, I'm sorry about the trouble. I really appreciate your help on this.
lol I'm not sure if Baldur's Gate: Enhanced Edition will work with another backend, but I'll post on the Beamdog forums about how that might be done :) Thanks again AVS and Warmonger

- Issue History
Date Modified Username Field Change
2015-08-16 20:07 Drake New Issue
2015-08-16 20:07 Drake Status new => assigned
2015-08-16 20:07 Drake Assigned To => Ivan
2015-08-16 20:07 Drake File Added: VCMI_Client_log.txt
2015-08-16 20:08 Drake File Added: VCMI_Launcher_log.txt
2015-08-16 20:10 Drake File Added: VCMI_client.exe_crashinfo.dmp.zip
2015-08-17 04:45 Warmonger Note Added: 0005776
2015-08-17 15:11 Drake Note Added: 0005778
2015-08-19 00:34 Drake Note Added: 0005779
2015-08-19 00:37 Drake Note Added: 0005780
2015-08-19 04:55 Warmonger Note Added: 0005781
2015-08-20 01:39 Drake Note Added: 0005782
2015-08-22 11:27 AVS Note Added: 0005783
2015-08-22 14:15 Drake Note Added: 0005784
2015-08-22 14:18 AVS Note Added: 0005785
2015-08-22 14:18 AVS Status assigned => resolved
2015-08-22 14:18 AVS Fixed in Version => 0.98d
2015-08-22 14:18 AVS Resolution open => no change required
2015-08-22 14:18 AVS Assigned To Ivan => AVS
2015-08-22 14:37 Drake Note Added: 0005788
2016-11-11 08:26 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2021 MantisBT Team
Hosting provided by DigitalOcean