MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002210VCMIMechanics - Battlespublic2015-06-12 01:242016-11-11 08:25
Reporterexfizik 
Assigned ToAVS 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinux 64 bitOSOpenSuseOS VersionTumbleweed
Product Version0.98b 
Target VersionFixed in Version0.98c 
Summary0002210: Enchanters don't cast spells
DescriptionEnchanters (those blue super-wizards) don't cast mass spells (well, any spells) during battle. They are supposed to do it on their own.
Steps To ReproduceStart a battle using Dragon Slayer campaign, wait for enchanters' turn and see them do nothing. The main hero can upgrade wizards to enchanters using his ability.
Additional InformationI'm using the latest git tree), says version 0.98c. You can try using attached saves.
TagsNo tags attached.
Attached Files? file icon NEWGAME1.vsgm1 [^] (3,418,530 bytes) 2015-06-12 01:24
zip file icon save.zip [^] (914,108 bytes) 2015-06-12 01:25

- Relationships

-  Notes
(0005743)
exfizik (reporter)
2015-06-12 01:25

Use save.zip, not the other file I attached by mistake.
(0005744)
exfizik (reporter)
2015-06-12 01:56

correction. They do cast spells - for example they cast weakness on air elementals. I suspect they didn't cast in my first battle because I was against earth elementals and whatever they were trying to cast didn't work on them... Just guessing. I think in that case they should've cast something good on my own troops, but they never did in the first battle.
(0005745)
exfizik (reporter)
2015-06-12 03:42

I guess you can remove this ticket - it only didn't work with the earth elementals... Worked on every battle since.
(0005747)
Warmonger (administrator)
2015-06-12 06:00

I still believe that Enchanters still should try to cast any spell if it's possible.
(0005759)
AVS (administrator)
2015-06-21 17:35
edited on: 2015-06-21 17:37

But they do not. There is a TODO note about that (CGameHandler.cpp:4221)

(0005761)
AVS (administrator)
2015-06-21 18:31

Should be fixed in https://github.com/vcmi/vcmi/commit/e27516a0b5ef2907ac48b00cc3c5efcd66cf80c3 [^]

- Issue History
Date Modified Username Field Change
2015-06-12 01:24 exfizik New Issue
2015-06-12 01:24 exfizik File Added: NEWGAME1.vsgm1
2015-06-12 01:25 exfizik File Added: save.zip
2015-06-12 01:25 exfizik Note Added: 0005743
2015-06-12 01:56 exfizik Note Added: 0005744
2015-06-12 03:42 exfizik Note Added: 0005745
2015-06-12 06:00 Warmonger Note Added: 0005747
2015-06-21 17:35 AVS Note Added: 0005759
2015-06-21 17:36 AVS Status new => confirmed
2015-06-21 17:37 AVS Note Edited: 0005759 View Revisions
2015-06-21 18:31 AVS Note Added: 0005761
2015-06-21 18:31 AVS Status confirmed => resolved
2015-06-21 18:31 AVS Fixed in Version => 0.98c
2015-06-21 18:31 AVS Resolution open => fixed
2015-06-21 18:31 AVS Assigned To => AVS
2016-11-11 08:25 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean