MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002168VCMIMechanics - Adventure Mappublic2015-04-04 14:582017-07-16 08:20
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.99 
Summary0002168: Terra incognito
DescriptionHero sometimes not open "Terra incognito"
TagsNo tags attached.
Attached Filesrar file icon Terra.rar [^] (464,346 bytes) 2015-04-04 14:58
png file icon Terra incognito.PNG [^] (46,101 bytes) 2015-04-04 14:59

- Relationships
related to 0002088assignedSXX Multiplayer: after capturing town Lookout Tower doesn't reveal map at all 
related to 0002345resolvedSXX Fog of War changing objects may completely cover heroes/towns 
related to 0002459resolvedSXX Desync found! - Work toward full sync of save games 

-  Notes
(0005871)
SXX (administrator)
2015-09-23 06:35

Just in case posting there some details on issue to not forget it. This issue appear because for some reason there is desync between client and server "fogOfWarMap" and this is why "vcmieagles" don't open these tiles.

So basically there is two possible cases why is that happen:
 - There is some code that modify FoW on server-side, but don't send FoWChange.
 - For some reason client ignore some FoWChanage packet.
(0005872)
Warmonger (administrator)
2015-09-23 07:43

I have an idea for complete overhaul for FoW update issues.
(0006209)
SXX (administrator)
2015-12-24 13:16
edited on: 2015-12-24 13:19

BTW it's looks like I find way to reproduce it:
- Get my V4 map from topic:
http://forum.vcmi.eu/viewtopic.php?t=1108 [^]
- Start game as green player.
- Use "vcmieagles" cheat.
Almost every time I do that part of FoW remaining there.

Currently it's looks like desync cause by scouting skill, but I suppose artifacts may cause it as well. Of course when no heroes there have scouting problem not appear.

(0006677)
SXX (administrator)
2016-09-16 03:21

Should be now resolved more or less with 0002459

- Issue History
Date Modified Username Field Change
2015-04-04 14:58 Povelitel New Issue
2015-04-04 14:58 Povelitel File Added: Terra.rar
2015-04-04 14:59 Povelitel File Added: Terra incognito.PNG
2015-09-14 13:08 Povelitel Relationship added related to 0002088
2015-09-23 06:35 SXX Note Added: 0005871
2015-09-23 07:43 Warmonger Note Added: 0005872
2015-12-24 13:07 SXX Relationship added related to 0002345
2015-12-24 13:16 SXX Note Added: 0006209
2015-12-24 13:19 SXX Note Edited: 0006209 View Revisions
2016-09-12 03:25 SXX Assigned To => SXX
2016-09-12 03:25 SXX Status new => assigned
2016-09-16 03:20 SXX Relationship added related to 0002459
2016-09-16 03:21 SXX Note Added: 0006677
2016-09-16 03:21 SXX Status assigned => resolved
2016-09-16 03:21 SXX Fixed in Version => 0.99
2016-09-16 03:21 SXX Resolution open => fixed
2017-07-16 08:20 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean