MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002134VCMIAI - Adventure Mappublic2015-03-12 15:332016-04-07 13:44
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97c 
Target VersionFixed in Version0.98f 
Summary0002134: Crash during AI turn - current tile invisible
Descriptiondon't know why happens. green player
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (1,416,485 bytes) 2015-03-12 15:33
txt file icon VCMI_Client_log.txt [^] (1,150,984 bytes) 2015-03-12 15:33
txt file icon VCMI_Server_log.txt [^] (513,863 bytes) 2015-03-12 15:34 [Show Content]

- Relationships
duplicate of 0002345resolvedSXX Fog of War changing objects may completely cover heroes/towns 

-  Notes
(0005651)
SXX (administrator)
2015-03-18 05:50
edited on: 2015-03-18 07:24

Useful part of backtrace:
0	std::vector<CGObjectInstance*>::size	stl_vector.h	646	0x7ffff6fbc272	
1	std::vector<CGObjectInstance*>::vector	stl_vector.h	312	0x7ffff70d834b	
2	TerrainTile::topVisitableObj	CMap.cpp	135	0x7ffff70d4db3	
3	VCAI::__lambda31::operator()	VCAI.cpp	1736	0x7fffcbb1a18b	
4	VCAI::moveHeroToTile	VCAI.cpp	1770	0x7fffcbb1aaa6	
5	VCAI::goVisitObj	VCAI.cpp	839	0x7fffcbb13783	
6	VCAI::wander	VCAI.cpp	1408	0x7fffcbb17870	
7	VCAI::performTypicalActions	VCAI.cpp	2321	0x7fffcbb1fff2	
8	VCAI::makeTurnInternal	VCAI.cpp	813	0x7fffcbb13075	
9	VCAI::makeTurn	VCAI.cpp	725	0x7fffcbb1259d	
10	boost::_mfi::mf0<void, VCAI>::operator()	mem_fn_template.hpp	49	0x7fffcbc34d21
...


This one occur in my code so I'll try to find out.

Problem possibly occur because AI trying to get information about tiles that isn't visible. Though it's really weird that it's occur within movement as this may mean there is bug somewhere else.

(0005944)
Povelitel (updater)
2015-10-14 09:52

Let me remind you, just in case, to avoid losing
Напомню на всякий случай, чтобы не потерялось :)
(0006159)
SXX (administrator)
2015-12-09 08:14

Sadly can't load this save due to some problem with bonus deserizlization: 0002314.
Though this one is clearly duplicate of 0002345

- Issue History
Date Modified Username Field Change
2015-03-12 15:33 Povelitel New Issue
2015-03-12 15:33 Povelitel Status new => assigned
2015-03-12 15:33 Povelitel Assigned To => Warmonger
2015-03-12 15:33 Povelitel File Added: Saves.rar
2015-03-12 15:33 Povelitel File Added: VCMI_Client_log.txt
2015-03-12 15:34 Povelitel File Added: VCMI_Server_log.txt
2015-03-17 10:59 Povelitel Product Version => 0.97c
2015-03-18 05:50 SXX Note Added: 0005651
2015-03-18 07:24 SXX Note Edited: 0005651 View Revisions
2015-03-21 15:05 SXX Summary Crash during AI turn => Crash during AI turn - current tile invisible
2015-03-21 15:06 SXX Assigned To Warmonger => SXX
2015-10-14 09:52 Povelitel Note Added: 0005944
2015-10-25 18:34 Warmonger Relationship added duplicate of 0002287
2015-10-25 18:45 Warmonger Relationship added has duplicate 0002274
2015-12-09 08:14 SXX Note Added: 0006159
2015-12-09 08:14 SXX Relationship added duplicate of 0002345
2015-12-09 08:14 SXX Status assigned => resolved
2015-12-09 08:14 SXX Fixed in Version => 0.98f
2015-12-09 08:14 SXX Resolution open => fixed
2015-12-09 08:15 SXX Relationship deleted has duplicate 0002274
2015-12-09 08:31 SXX Relationship deleted 0002287
2016-04-07 13:44 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean