MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002090VCMIMechanics - Town structurespublic2015-02-15 11:142015-04-11 18:08
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97b 
Target VersionFixed in Version0.98 
Summary0002090: All towns with default buildings get Tovern on start of game
Descriptionit is necessary to build the most
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005519)
SXX (administrator)
2015-02-15 22:38

Not sure what you mean here. Please post in russian if you can.
(0005521)
Povelitel (updater)
2015-02-16 01:01

Хочу сказать что в городах "по умолчанию" отстроены таверны. Даже если сгенерировать случайную карту в Соде и положить в всми папку, то все равно когда начнешь играть в всми таверны будут отстроены в городах которые ты захватываешь. Нейтральные города я имею ввиду. То есть сразу можно строить 1000.

В соде захватил нейтральный город - будь любезен сначала таверну поставь, а потом уже и 1000 строй. А тут можно сразу, по умолчанию она отстроена почему то.
(0005522)
SXX (administrator)
2015-02-16 06:51

Спасибо, проверю.
(0005632)
SXX (administrator)
2015-03-12 15:32
edited on: 2015-03-12 15:43

So I checked H3 behaviour and it's looks like:
1 - Player-owned towns always get tavern on start of game. Even if player start with multiple towns and town don't have "Has fort" option checked.
2 - Cities not owned by player never start with Tavern.

As far as I see this can be easily fixed in CGameState::initTowns.

(0005634)
SXX (administrator)
2015-03-12 15:52

Fixed in git:
https://github.com/vcmi/vcmi/commit/32009690eb6e37009e71bdce5e85a3b08297fcaf [^]

- Issue History
Date Modified Username Field Change
2015-02-15 11:14 Povelitel New Issue
2015-02-15 22:38 SXX Note Added: 0005519
2015-02-16 01:01 Povelitel Note Added: 0005521
2015-02-16 06:51 SXX Note Added: 0005522
2015-03-12 15:25 SXX Assigned To => SXX
2015-03-12 15:25 SXX Status new => assigned
2015-03-12 15:32 SXX Note Added: 0005632
2015-03-12 15:43 SXX Note Edited: 0005632 View Revisions
2015-03-12 15:44 SXX Summary tavern always rebuilt. Other cities that you capture => All towns with default buildings get Tovern on start of game
2015-03-12 15:52 SXX Note Added: 0005634
2015-03-12 15:52 SXX Status assigned => resolved
2015-03-12 15:52 SXX Fixed in Version => 0.98
2015-03-12 15:52 SXX Resolution open => fixed
2015-04-11 18:08 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean