MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002075VCMIGUI - Otherpublic2015-02-14 03:232015-03-11 16:30
ReporterSXX 
Assigned ToAVS 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97b 
Target VersionFixed in Version0.97c 
Summary0002075: Kingdom Overview: attempt to pick equipped combined artifact cause crash
DescriptionIn same time you can easily take combined artifact from backpack on this screen and equip it, but reverse cause crash.
Additional Information
0	CArtPlace::select	CArtifactHolder.cpp	279	0x6a73c4	
1	CArtPlace::clickLeft	CArtifactHolder.cpp	148	0x6a6800	
2	CGuiHandler::handleEvent	CGuiHandler.cpp	321	0x6722e4	
3	CGuiHandler::handleEvents	CGuiHandler.cpp	183	0x6716e1	
4	CPlayerInterface::update	CPlayerInterface.cpp	1599	0x942889	
5	CGuiHandler::__lambda4::operator()	CGuiHandler.cpp	417	0x672ae9	
6	std::_Function_handler<void(IUpdateable*), CGuiHandler::renderFrame()::__lambda4>::_M_invoke(const 
std::_Any_data &, IUpdateable *)	functional	2071	0x6739af	
7	std::function<void (IUpdateable*)>::operator()(IUpdateable*) const	functional	2464	0x679b5b	

8	CPlayerInterface::runLocked(std::function<void (IUpdateable*)>)	CPlayerInterface.cpp	1638	0x942b33	

9	CGuiHandler::renderFrame	CGuiHandler.cpp	431	0x672c17	
10	mainLoop	CMT.cpp	1197	0x904c2b	
11	main	CMT.cpp	485	0x8ff7d6	
TagsNo tags attached.
Attached Files

- Relationships
related to 0001309closedAVS Active artifacts are not picked up properly 

-  Notes
(0005475)
AVS (administrator)
2015-02-14 12:45
edited on: 2015-02-14 12:54

The problem is misc5 artifact slot. I`ve fixed crash an will push fix soon. But need more work for complete fix

(0005476)
AVS (administrator)
2015-02-14 13:06
edited on: 2015-02-14 13:16

Crash is fixed - no I`ll rework kingdom interface a bit. Catapult will be removed and misc5 slot will be added. But it is another issue)

(0005477)
SXX (administrator)
2015-02-14 15:08

Confirm that crash is fixed.
(0005478)
SXX (administrator)
2015-02-14 15:09

For anyone interested here is commit:
https://github.com/vcmi/vcmi/commit/c8a16bb324dd42e72aab1de0e2c7e4d557a17092 [^]

- Issue History
Date Modified Username Field Change
2015-02-14 03:23 SXX New Issue
2015-02-14 11:37 AVS Status new => confirmed
2015-02-14 12:19 AVS Assigned To => AVS
2015-02-14 12:19 AVS Status confirmed => assigned
2015-02-14 12:45 AVS Note Added: 0005475
2015-02-14 12:54 AVS Note Edited: 0005475 View Revisions
2015-02-14 13:06 AVS Note Added: 0005476
2015-02-14 13:16 AVS Note Edited: 0005476 View Revisions
2015-02-14 13:16 AVS Status assigned => resolved
2015-02-14 13:16 AVS Fixed in Version => 0.97c
2015-02-14 13:16 AVS Resolution open => fixed
2015-02-14 15:08 SXX Note Added: 0005477
2015-02-14 15:09 SXX Note Added: 0005478
2015-02-14 15:09 SXX Status resolved => closed
2015-03-11 16:30 SXX Relationship added related to 0001309

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean