MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001309VCMIGUI - Otherpublic2013-06-09 03:212016-11-11 08:22
Reporterfenix.citizen 
Assigned ToAVS 
PrioritylowSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformNTOSWindowsOS VersionWin7 HP
Product Version0.93 
Target VersionFixed in Version0.97c 
Summary0001309: Active artifacts are not picked up properly
DescriptionArtifacts that are present in a hero's active side inventory (the five empty slots on the left hand side) are not picked up in the kingdom summary in the Active category.
TagsNo tags attached.
Attached Filesjpg file icon hero_summary.jpg [^] (510,302 bytes) 2013-06-09 03:21


png file icon bug1309-correct.png [^] (85,154 bytes) 2013-06-09 04:51


jpg file icon hero_summary2.jpg [^] (695,115 bytes) 2013-06-09 05:04

- Relationships
related to 0002075closedAVS Kingdom Overview: attempt to pick equipped combined artifact cause crash 

-  Notes
(0003676)
Warmonger (administrator)
2013-06-09 04:50
edited on: 2013-06-09 04:51

Because they should not. There are not enough slots to hold misc artifacts, instead they are present in "Miscellaneous" tab, check attached screenshot.

(0003677)
fenix.citizen (reporter)
2013-06-09 05:05

Ha! The problem seems to be limited to the fifth slot only. It is not present in either Active or Miscellaneous section. See the screenshot please.
(0003678)
fenix.citizen (reporter)
2013-06-09 05:09

Irrespective of the above, why cannot we have the scrolling functionality like for the "In Backpack" section?
(0003679)
Warmonger (administrator)
2013-06-09 05:11

There is 1 slot for Spellbook and 4 slots for War Machines, leaving only 4 slots for misc artifacts. No way to handle that with original interface.
(0003680)
fenix.citizen (reporter)
2013-06-09 05:16

What do you mean by the original interface? Can you please elaborate? Do you mean that scrolling cannot be used for misc artifacts?
(0005618)
SXX (administrator)
2015-03-11 16:29

@AVS has fixed this one while fixing 0002075
https://github.com/vcmi/vcmi/commit/0b546a9b9fc448275cd49058509484b248c1574c [^]
https://github.com/vcmi/vcmi/commit/c8a16bb324dd42e72aab1de0e2c7e4d557a17092 [^]

Now Kingdom Overview don't display contents of catapult slot and as result there is enough space for all 5 misc slots.

- Issue History
Date Modified Username Field Change
2013-06-09 03:21 fenix.citizen New Issue
2013-06-09 03:21 fenix.citizen File Added: hero_summary.jpg
2013-06-09 04:50 Warmonger Note Added: 0003676
2013-06-09 04:51 Warmonger Note Edited: 0003676 View Revisions
2013-06-09 04:51 Warmonger File Added: bug1309-correct.png
2013-06-09 04:51 Warmonger Note Edited: 0003676 View Revisions
2013-06-09 04:51 Warmonger Status new => feedback
2013-06-09 05:04 fenix.citizen File Added: hero_summary2.jpg
2013-06-09 05:05 fenix.citizen Note Added: 0003677
2013-06-09 05:05 fenix.citizen Status feedback => new
2013-06-09 05:09 fenix.citizen Note Added: 0003678
2013-06-09 05:11 Warmonger Note Added: 0003679
2013-06-09 05:16 fenix.citizen Note Added: 0003680
2015-03-11 16:29 SXX Note Added: 0005618
2015-03-11 16:29 SXX Status new => resolved
2015-03-11 16:29 SXX Fixed in Version => 0.97c
2015-03-11 16:29 SXX Resolution open => fixed
2015-03-11 16:29 SXX Assigned To => AVS
2015-03-11 16:30 SXX Relationship added related to 0002075
2016-11-11 08:22 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean