MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002057VCMIGUI - PreGamepublic2015-02-08 10:302015-10-15 02:38
ReporterSXX 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97b 
Target VersionFixed in Version0.98 
Summary0002057: Scrolling of custom campaign list mess up it
DescriptionLikely when list scrolled new text is rendered on top of old one that's not being removed. Though once you click on any entry old text being cleaned up.

There also two other improvements that screen need:
 - Campaign title max lenght need to be enforced.
 - Description may go a bit upper and there no reason to enable scroll as there tons of free space.
Anyway two of these don't break this page while main issue is annoying.
Steps To Reproduce  - Put enough H3C's into Maps directory so scrolling works.
  - Go into New Game -> Campaign -> Custom
  - Try to scroll list using buttons or mouse wheel
TagsNo tags attached.
Attached Filespng file icon screen.png [^] (1,327,240 bytes) 2015-02-08 10:30

- Relationships
related to 0002101closedSXX Multiplayer chat does not work 

-  Notes
(0005647)
SXX (administrator)
2015-03-13 14:51

So I met similar problem with multiplayer mode chatbox so decide to investigate this. Looks like problem occur because in "SelectionTab::SelectionTab" background is set to nullptr and comment says background from parent would be used.

Though it's looks like this only cause glitch to appear possible because when campaign list redrawn occur background isn't redrawn too.
(0005648)
SXX (administrator)
2015-03-13 15:48

Fixed in git:
https://github.com/vcmi/vcmi/commit/1f1f61cf1503a7cb0a43289717c2bc93218a4a2e [^]

- Issue History
Date Modified Username Field Change
2015-02-08 10:30 SXX New Issue
2015-02-08 10:30 SXX Status new => assigned
2015-02-08 10:30 SXX Assigned To => Tow
2015-02-08 10:30 SXX File Added: screen.png
2015-03-13 14:48 SXX Assigned To Tow => SXX
2015-03-13 14:51 SXX Note Added: 0005647
2015-03-13 14:52 SXX Relationship added related to 0002101
2015-03-13 15:48 SXX Note Added: 0005648
2015-03-13 15:48 SXX Status assigned => resolved
2015-03-13 15:48 SXX Fixed in Version => 0.98
2015-03-13 15:48 SXX Resolution open => fixed
2015-10-15 02:38 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean