MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002034VCMIRandom Map Generatorpublic2015-01-09 18:252015-04-11 18:07
ReporterPovelitel 
Assigned ToWarmonger 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97b 
Target VersionFixed in Version0.97c 
Summary0002034: monsters join without diplomacy
DescriptionI do not know for sure whether or not this is a bug, perhaps these settings in a template. But there is usually a never join if you do not diplomacy. Join only those creatures that have appeared on the map as a consequence of the monster of the week. Pegasus, harpies, imps and so on. But not the ones that created the generator itself
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005369)
Warmonger (administrator)
2015-01-09 19:11

Then come back when you are sure. There are many resources about game mechanics, especially Strategija. Certainly monsters can join without diplomacy.
I'm not sure what monster settings are used on random maps, though.
(0005370)
Povelitel (updater)
2015-01-10 08:43

I played about 300 games online on random maps. And I have never seen monsters to join without diplomacy.
Except those announcing month monster. Gogi, Pegasus, harpies, gremlins, and so on.
All because they were seen as "hostile" monsters.

160% difficult
(0005371)
Warmonger (administrator)
2015-01-10 09:29

Editor shows all monsters are generated with 'Hostile' character.

Fixed in https://github.com/vcmi/vcmi/commit/9f05f53e65fe9783a050cde20d47a5218b5fd6a1 [^]

- Issue History
Date Modified Username Field Change
2015-01-09 18:25 Povelitel New Issue
2015-01-09 18:26 Povelitel Description Updated View Revisions
2015-01-09 19:11 Warmonger Note Added: 0005369
2015-01-10 08:43 Povelitel Note Added: 0005370
2015-01-10 09:29 Warmonger Note Added: 0005371
2015-01-10 09:29 Warmonger Status new => resolved
2015-01-10 09:29 Warmonger Fixed in Version => 0.97c
2015-01-10 09:29 Warmonger Resolution open => fixed
2015-01-10 09:29 Warmonger Assigned To => Warmonger
2015-04-11 18:07 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean