MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001913VCMIMechanics - Adventure Mappublic2014-10-07 16:272015-04-11 18:08
ReporterPovelitel 
Assigned ToFay 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.96b 
Target VersionFixed in Version0.97c 
Summary0001913: At the entrance to the Subterranean Gate, the camera does not move for your hero
DescriptionAt the entrance to the Subterranean Gate, the camera does not move for your hero
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005002)
Warmonger (administrator)
2014-10-07 18:12

The same is true for Monolith, Town Portal and Dimension Door... probably everything that moves hero around.
(0005412)
SXX (administrator)
2015-02-06 15:15

Still actual and here one more important detail: if for example your hero stay on monolith's with 3+ points then when you press space camera actually does move to place where hero was located before teleportation.
(0005413)
Fay (developer)
2015-02-06 16:12

I can make a fix for this later. Can't check now for sure, but I think I fixed it while testing fading screen in adv map. :)
(0005414)
SXX (administrator)
2015-02-06 16:27
edited on: 2015-02-06 16:27

Great. Actually I'm find out that it's happen because server do sent information that hero move before he's visited object, but not after he's actually activated Monolith / Subterranean Gate / etc.

Please comment here if this fixed or still need attention. :-)

(0005415)
Fay (developer)
2015-02-06 18:21

I created pull request: https://github.com/vcmi/vcmi/pull/82 [^]
I tested it on subterranean gates, monoliths, town portals and dimension doors and it seemed to work correctly.

If you want, you could also check it in the branch: https://github.com/Fayth/vcmi/tree/test/advMapFading [^] -- all these cases should work with screen fading (but there are still some problems with fading heroes/boats so it's not ready for PR yet ;) ).

@SXX "Actually I'm find out that it's happen because server do sent information that hero move before he's visited object, but not after he's actually activated Monolith / Subterranean Gate / etc"
Well, I think server does send it, but client didn't update the camera correctly. I might be wrong though, because I haven't really looked into client/server communication.
(0005416)
AVS (administrator)
2015-02-06 20:44

PR 82 has been merged
(0005420)
SXX (administrator)
2015-02-07 03:17

@Fay. Yeah just seen it. You're totally right.
Checked and now it's working fine. :-)

- Issue History
Date Modified Username Field Change
2014-10-07 16:27 Povelitel New Issue
2014-10-07 18:12 Warmonger Note Added: 0005002
2014-10-29 19:12 Warmonger Status new => confirmed
2015-02-06 15:15 SXX Note Added: 0005412
2015-02-06 16:12 Fay Note Added: 0005413
2015-02-06 16:27 SXX Note Added: 0005414
2015-02-06 16:27 SXX Note Edited: 0005414 View Revisions
2015-02-06 18:21 Fay Note Added: 0005415
2015-02-06 20:44 AVS Note Added: 0005416
2015-02-06 20:44 AVS Status confirmed => resolved
2015-02-06 20:44 AVS Fixed in Version => 0.97c
2015-02-06 20:44 AVS Resolution open => fixed
2015-02-06 20:44 AVS Assigned To => Fay
2015-02-07 03:17 SXX Note Added: 0005420
2015-04-11 18:08 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean