MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001912VCMIMechanics - Objectspublic2014-10-07 16:122015-04-11 18:07
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.96b 
Target VersionFixed in Version0.97b 
Summary0001912: Stables not give a bonus movement points?
DescriptionDrew attention to that when you visit the stables are not added to points of movement. (400)
Additional InformationAt least in this save game
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (1,256,330 bytes) 2014-10-07 16:12

- Relationships
has duplicate 0001942closedSXX Stables doesn't work, no text message 
has duplicate 0001938closedSXX Faerie Ring doesn't work and shows no text 
has duplicate 0001943closedSXX Bouy doesn't work - no effect, no text message 
has duplicate 0001940closedSXX Idol of Fortune doesn't work, no text message 
has duplicate 0001939closedSXX Swan Pond doesn't work, no text message 
has duplicate 0001972closedSXX after loading saves stables stop working 
related to 0001989closedvmarkovtsev Stables not grade cavaliers in champions 

-  Notes
(0005226)
SXX (administrator)
2014-12-20 14:37
edited on: 2014-12-20 14:42

This problem described a bit better in 0001972: problem only occur after you load save game.
All objects using CGBonusingObject handler affected:

  - Obj::BUOY
  - Obj::SWAN_POND
  - Obj::FAERIE_RING
  - Obj::FOUNTAIN_OF_FORTUNE
  - Obj::IDOL_OF_FORTUNE
  - Obj::MERMAID
  - Obj::RALLY_FLAG
  - Obj::OASIS
  - Obj::TEMPLE
  - Obj::WATERING_HOLE
  - Obj::FOUNTAIN_OF_YOUTH
  - Obj::STABLES

Investigate this one as moment. So far I notice that "CGBonusingObject::initObj" not called on loading of save.
This possible because all objects state have to be loaded from save already or this is reason of problem.

(0005232)
SXX (administrator)
2014-12-20 15:14

So according to logs when "CRewardableObject::onHeroVisit" check what rewards are available "CRewardableObject::getAvailableRewards" return there is zero rewards available for this object.
(0005233)
Warmonger (administrator)
2014-12-20 15:20
edited on: 2014-12-20 15:20

Probably some property is not serialized (once again).

(0005234)
SXX (administrator)
2014-12-20 15:48

Yeah.

@AVS already gived me a hint that problem occur because it's serializes CGObjectInstance and not CRewardableObject.
(0005247)
SXX (administrator)
2014-12-22 09:44

https://github.com/vcmi/vcmi/pull/67 [^]
(0005280)
SXX (administrator)
2014-12-25 14:06

Should be now fixed in git:
https://github.com/vcmi/vcmi/commit/5d59bbc0d4fd80cc14deba7de0c0f26016dc4e1c [^]
(0005283)
Warmonger (administrator)
2014-12-25 19:11

It's better to mark all related reports as "resolved in 0.next" so people can see it in a changelog. You can close them later.
(0005286)
SXX (administrator)
2014-12-25 19:36

Done. Hope it's what you mean :-)

- Issue History
Date Modified Username Field Change
2014-10-07 16:12 Povelitel New Issue
2014-10-07 16:12 Povelitel Status new => assigned
2014-10-07 16:12 Povelitel Assigned To => Warmonger
2014-10-07 16:12 Povelitel File Added: Saves.rar
2014-11-10 12:31 Warmonger Relationship added has duplicate 0001942
2014-12-10 21:43 Warmonger Relationship added related to 0001989
2014-12-20 14:37 SXX Note Added: 0005226
2014-12-20 14:37 SXX Relationship added has duplicate 0001938
2014-12-20 14:37 SXX Relationship added related to 0001939
2014-12-20 14:38 SXX Relationship added related to 0001940
2014-12-20 14:38 SXX Relationship added has duplicate 0001943
2014-12-20 14:38 SXX Relationship deleted related to 0001940
2014-12-20 14:38 SXX Relationship deleted related to 0001939
2014-12-20 14:38 SXX Relationship added has duplicate 0001940
2014-12-20 14:39 SXX Relationship added related to 0001939
2014-12-20 14:39 SXX Relationship deleted related to 0001939
2014-12-20 14:39 SXX Relationship added has duplicate 0001939
2014-12-20 14:39 SXX Relationship added has duplicate 0001972
2014-12-20 14:40 SXX Note Edited: 0005226 View Revisions
2014-12-20 14:42 SXX Note Edited: 0005226 View Revisions
2014-12-20 15:14 SXX Note Added: 0005232
2014-12-20 15:20 Warmonger Note Added: 0005233
2014-12-20 15:20 Warmonger Note Edited: 0005233 View Revisions
2014-12-20 15:48 SXX Note Added: 0005234
2014-12-21 11:27 SXX Assigned To Warmonger => SXX
2014-12-22 09:44 SXX Note Added: 0005247
2014-12-25 14:06 SXX Note Added: 0005280
2014-12-25 14:06 SXX Status assigned => resolved
2014-12-25 14:06 SXX Fixed in Version => 0.97b
2014-12-25 14:06 SXX Resolution open => fixed
2014-12-25 19:11 Warmonger Note Added: 0005283
2014-12-25 19:36 SXX Note Added: 0005286
2015-04-11 18:07 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean