MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001835VCMIOtherpublic2014-07-12 12:122018-11-07 06:47
ReporterNikolay.IT 
Assigned ToWarmonger 
PriorityhighSeveritycrashReproducibilityN/A
StatusresolvedResolutionunable to reproduce 
Platform64 bitOSWindows 8OS Version
Product Version0.96 
Target VersionFixed in Version0.next 
Summary0001835: Crash on end turn
DescriptionDisaster happened.
Reason: 0xc0000005 - EXCEPTION_ACCESS_VIOLATION at 0023:5A10BA4E
Attempt to read from 0x00000000
Thread ID: 11176 [11176]
Crash info will be put in VCMI_client.exe_crashinfo.dmp
Steps To Reproduce1. Load the given save file
2. Click end turn
3. The game crashes
TagsNo tags attached.
Attached Fileszip file icon _report.zip [^] (1,387,420 bytes) 2014-07-12 12:12
zip file icon vcmi.crash.zip [^] (976,958 bytes) 2014-07-17 15:12
zip file icon savegame.zip [^] (958,132 bytes) 2014-07-20 19:58

- Relationships
related to 0001839closedTow Crash turn AI 
related to 0001840closedTow Crash turn AI 

-  Notes
(0004838)
amergl (reporter)
2014-07-16 15:06

The same problem I encountered under Debian Wheezy. If you require I can upload the saved game status.

There are two other but very similar tickets 0001839 and 0001840 reporting this bug.

Is it new in version 0.96?
(0004839)
Ivan (developer)
2014-07-16 15:41

amergl, upload saves and logs so we can make sure that this is the same bug.

Logs are usually in ~/.cache/vcmi/ directory, saves are in ~/.local/share/vcmi/Saves
(0004840)
amergl (reporter)
2014-07-17 15:14

dear Ivan,

as you requested done, see attached vcmi.crash.zip

Attila
(0004841)
Ivan (developer)
2014-07-17 18:16

Thanks. Yes, looks to be at least similar. All 3 issues have a crash during AI turn so I've marked them as related.
(0004852)
giff (reporter)
2014-07-20 19:57

Most likely same issue on Ubuntu 14.04. Console output:

Another allied hero stands in our way
Another allied hero stands in our way
Another allied hero stands in our way
Our heroes don't move anymore, exhaustive decomposition failed
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
vcmiclient: ../../src/xcb_io.c:179: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
Aborted (core dumped)


Save game attached (savegame.zip)
(0004914)
sirenry (reporter)
2014-08-13 01:27

Same issue here. Ubuntu 14.04 also. Kind of annoying, since I just discovered this, and now I can't play past a few turns :(

Can provide saved game / more logs if necessary, very easy to reproduce (it's happened to me on 2 different games, after a week or so).

Where it says "SNIP" there are about 70 copies omitted of the allied hero error.
Maybe some sort of infinite recursion for pathfinding..?

Full terminal output:

Opening VCAI
Loaded VCAI
Opening StupidAI
Loaded Stupid AI 0.1
Loaded client part of save 284
Establishing connection...
Found endpoints:
    0: 127.0.0.1:3030
Trying connection to 127.0.0.1:3030 (0)
Established connection with VCMI 0.96 (server)
    Connecting to the server: 9
Server opened savegame properly.
Sent info to server: 55
Warning: IntObject re-activated with mismatching used and active
Player 1 starting turn
Another allied hero stands in our way
Another allied hero stands in our way

  - - - - SNIP - - - -
Another allied hero stands in our way
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
vcmiclient: ../../src/xcb_io.c:274: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
(0004918)
Nikolay.IT (reporter)
2014-08-16 07:41

It happens in almost every game. It's very annoying.
(0007679)
Povelitel (updater)
2018-11-06 14:52

Saves are very old and impossible to check. The AI has been improved during this time and I believe this ticket is no longer relevant.

- Issue History
Date Modified Username Field Change
2014-07-12 12:12 Nikolay.IT New Issue
2014-07-12 12:12 Nikolay.IT File Added: _report.zip
2014-07-16 15:06 amergl Note Added: 0004838
2014-07-16 15:41 Ivan Note Added: 0004839
2014-07-17 15:12 amergl File Added: vcmi.crash.zip
2014-07-17 15:14 amergl Note Added: 0004840
2014-07-17 18:11 Ivan Relationship added related to 0001839
2014-07-17 18:11 Ivan Relationship added related to 0001840
2014-07-17 18:16 Ivan Note Added: 0004841
2014-07-20 19:57 giff Note Added: 0004852
2014-07-20 19:58 giff File Added: savegame.zip
2014-08-13 01:27 sirenry Note Added: 0004914
2014-08-16 07:41 Nikolay.IT Note Added: 0004918
2018-11-06 14:52 Povelitel Note Added: 0007679
2018-11-06 14:52 Povelitel Status new => resolved
2018-11-06 14:52 Povelitel Fixed in Version => 0.next
2018-11-06 14:52 Povelitel Resolution open => fixed
2018-11-06 14:52 Povelitel Assigned To => Warmonger
2018-11-07 06:47 AVS Reproducibility always => N/A
2018-11-07 06:47 AVS Resolution fixed => unable to reproduce

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean