MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001733VCMILauncherpublic2014-02-27 11:352014-08-01 12:08
ReporterKantor 
Assigned ToIvan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.94f 
Target VersionFixed in Version0.95b 
Summary0001733: Launcher changing resolution option doesn't work.
DescriptionAs in the summary, changing this option does nothing, you have to change the resolution in game. The option to change fullscreen\windowed mode also doesn't work.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001688resolvedSXX On Windows vcmi must store user-specific data under C:\Users directory 

-  Notes
(0004535)
Ivan (developer)
2014-02-27 12:01

Why I'm so lucky to get non-reproducible issues? :(

Works for me yet again. Can you check content of config/settings.json - does launcher updates it correctly?
(0004536)
Kantor (updater)
2014-02-27 12:54

Yes, the settings.json file is updated correctly every time I change the resolution in launcher but, heh, it still not affects the game.
(0004537)
Kantor (updater)
2014-02-27 13:49

Another epic discovery ;)
You probably know about Warmonger's mod 'AI trace' - it's a single file - settings.json and in this file has also been saved informations about resolution. So VCMI was reading resolution from the mod instead of original config/settings.json file.
(0004538)
Ivan (developer)
2014-02-27 13:56

Ah. And Launcher always reads from file in config directory.

Proper fix would need fixing 0001688 first though. Not sure what I can do at the moment...
(0004582)
Ivan (developer)
2014-03-08 16:06

fixed, rev 3802

- Issue History
Date Modified Username Field Change
2014-02-27 11:35 Kantor New Issue
2014-02-27 11:35 Kantor Status new => assigned
2014-02-27 11:35 Kantor Assigned To => Ivan
2014-02-27 12:01 Ivan Note Added: 0004535
2014-02-27 12:54 Kantor Note Added: 0004536
2014-02-27 13:49 Kantor Note Added: 0004537
2014-02-27 13:56 Ivan Note Added: 0004538
2014-02-27 13:58 Ivan Relationship added related to 0001688
2014-03-08 16:06 Ivan Note Added: 0004582
2014-03-08 16:06 Ivan Status assigned => resolved
2014-03-08 16:06 Ivan Fixed in Version => 0.95b
2014-03-08 16:06 Ivan Resolution open => fixed
2014-08-01 12:08 Kantor Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean