MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001719VCMICampaignspublic2014-02-23 13:492014-06-02 10:13
Reporterbeegee 
Assigned ToTow 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.95 
Summary0001719: Crash when starting campaign Unholy Alliance scenario 8 Invasion
DescriptionGame crashes when map of campaign Unholy Alliance scenario 8 Invasion will be loaded.
Additional InformationConsole output:

Starting scenario 7
Setting up thread calling server: 0
Waiting for server: 29
Establishing connection...
Found endpoints:
    0: 127.0.0.1:3030
Trying connection to 127.0.0.1:3030 (0)
Established connection with VCMI 0.94e (server)
    Connecting to the server: 6
    Will send info to server...
vcmiserver: /home/bge/VCMI/trunk/src/lib/NetPacksLib.cpp:666: void ArtifactLocation::removeArtifact(): Assertion `a' failed.
sh: Zeile 1: 5589 Abgebrochen (Speicherabzug geschrieben) /usr/local/bin/vcmiserver --port=3030 > /home/bge/.vcmi/server_log.txt
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what(): read: End of file

Last lines of VCMI_Server_log.txt:
14:42:33 DEBUG global [7f5053c24780] - Generate list of hero placeholders
14:42:33 DEBUG global [7f5053c24780] - Prepare crossover heroes
14:42:33 TRACE bonus [7f5053c24780] - Hero Gelu #detached from# Artifact instance of Catapult type
14:42:33 TRACE bonus [7f5053c24780] - Hero Gelu #detached from# Artifact instance of Hourglass of the Evil Hour type
14:42:33 TRACE bonus [7f5053c24780] - Hero Gem #detached from# Artifact instance of First Aid Tent type
14:42:33 TRACE bonus [7f5053c24780] - Hero Gem #detached from# Artifact instance of Catapult type
14:42:33 TRACE bonus [7f5053c24780] - Hero Yog #detached from# Artifact instance of Catapult type
14:42:33 TRACE bonus [7f5053c24780] - Hero Crag Hack #detached from# Artifact instance of Catapult type
14:42:33 WARN network [7f5053c24780] - ArtifactLocation::getArt: That location is locked!
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0001699closedIvan 0.94E - Sod - Unholy Alliance - Invasion 
related to 0001683closedbeegee Crash in company 
related to 0001723closedvmarkovtsev Quest Guard: crash when attempt to remove part of combined artifact 

-  Notes
(0004556)
Tow (developer)
2014-03-01 17:42

Fixed in r3790.
(0004721)
Kantor (updater)
2014-06-02 10:13

This one may be closed.

- Issue History
Date Modified Username Field Change
2014-02-23 13:49 beegee New Issue
2014-02-23 14:47 beegee Relationship added related to 0001683
2014-02-24 14:07 Ivan Relationship added duplicate of 0001699
2014-03-01 17:42 Tow Note Added: 0004556
2014-03-01 17:42 Tow Status new => resolved
2014-03-01 17:42 Tow Fixed in Version => 0.95
2014-03-01 17:42 Tow Resolution open => fixed
2014-03-01 17:42 Tow Assigned To => Tow
2014-03-01 17:59 Tow Relationship added related to 0001723
2014-06-02 10:13 Kantor Note Added: 0004721
2014-06-02 10:13 Kantor Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean