MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001685VCMIModspublic2014-02-02 08:482014-06-02 09:54
ReporterWarmonger 
Assigned ToIvan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.95b 
Summary0001685: If we use mod to change config/settings.json, all option changes are saved to that file
DescriptionBy default, custom user changes should go to his own confing/settings.json file and not the mod file.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001688resolvedSXX On Windows vcmi must store user-specific data under C:\Users directory 

-  Notes
(0004380)
Ivan (developer)
2014-02-02 08:55

I think I got an idea on how to fix these. As result both settings.json and modSettings.json from mods will be ignored.
(0004401)
Warmonger (administrator)
2014-02-02 21:02

Well, not all should be ignored - check Launcher my latest minimod that turns on AI logging.
(0004406)
Ivan (developer)
2014-02-08 12:38

In this case - this issue will have to wait until Tow will implement storing settings somewhere under C:\Users\... on Win.

Because if I'll change priority of "<data>/config" directory to highest this will disallow overriding of files in this directory by mods and will break at least WoG and high-res menu.

Alternatively you can create mod that replaces <data>/config/schemas/settings.json so "AI logging enabled" will be considered as default settings.
(0004581)
Ivan (developer)
2014-03-08 13:44
edited on: 2014-03-08 13:46

Good news: VCMI always saves changes to global file instead of file from mod.

Bad news: All non-default settings will go to this file. So if player uninstalls AI trace mod AI logging will remain because this change is already part of settings.json. And I don't see any easy way to fix this.

I'll commit these changes soon. If you wish - you can create mod that changes schema instead.

BTW - these changes will also fix those problems with mods replacing modSettings.json file.

(0004583)
Ivan (developer)
2014-03-08 16:07

fixed, rev 3802

Should work as described in my last comment - can't do anything else here.
(0004719)
Kantor (updater)
2014-06-02 09:54

This one may be closed.

- Issue History
Date Modified Username Field Change
2014-02-02 08:48 Warmonger New Issue
2014-02-02 08:52 Warmonger Summary If we use mod to change config/settings.json, all option changes are svaed to that file => If we use mod to change config/settings.json, all option changes are saved to that file
2014-02-02 08:54 Ivan Assigned To => Ivan
2014-02-02 08:54 Ivan Status new => assigned
2014-02-02 08:55 Ivan Note Added: 0004380
2014-02-02 21:02 Warmonger Note Added: 0004401
2014-02-08 12:38 Ivan Note Added: 0004406
2014-02-08 12:44 Ivan Relationship added related to 0001688
2014-03-08 13:44 Ivan Note Added: 0004581
2014-03-08 13:46 Ivan Note Edited: 0004581 View Revisions
2014-03-08 16:07 Ivan Note Added: 0004583
2014-03-08 16:07 Ivan Status assigned => resolved
2014-03-08 16:07 Ivan Fixed in Version => 0.95b
2014-03-08 16:07 Ivan Resolution open => fixed
2014-06-02 09:54 Kantor Note Added: 0004719
2014-06-02 09:54 Kantor Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean