MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001590VCMIAI - Adventure Mappublic2013-11-17 13:502016-04-07 13:37
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionWindows7 sp1
Product Version0.94 
Target VersionFixed in Version0.98g 
Summary0001590: border guard - useless expenditure of a turn.
DescriptionThe blue and green heroes tries to open infinitely border guard, can't remember
that he didn't visit tent! Also spends completely the turn, and several heroes.

http://youtu.be/BL-Bf-CvWNU [^]

Probably an example not so successful (because he has no place to go). But it spends real time of the player. Absolutely useless actions.

Tuning is necessary :)
TagsNo tags attached.
Attached Filesrar file icon border guard.rar [^] (833,136 bytes) 2013-11-17 13:50
? file icon testowanie mantisa.h3m [^] (5,926 bytes) 2014-06-01 20:10

- Relationships
related to 0002374assignedSXX VisitHero::fulfillsMe goal check used after battle with killed hero 
has duplicate 0002096closedSXX Freeze. AI infinitely try open Border Quard 
related to 0002383resolvedSXX AI infinitely loops with this save - secSkill desync 
related to 0002326resolvedSXX AI turn takes really long when there is many completely blocked heroes 

-  Notes
(0004196)
Warmonger (administrator)
2013-12-21 20:50

Oh yes nice psy.
(0004197)
Warmonger (administrator)
2013-12-21 21:33

Fixed in r3670.
(0004696)
Kantor (updater)
2014-06-01 20:09

This one is still an issue. I'm including a map.
(0004697)
Kantor (updater)
2014-06-01 20:12

The AI is still wasting it's move on border guard.
(0006404)
Povelitel (updater)
2016-02-04 13:50

it's may be related? bugs.vcmi.eu/view.php?id=2096
(0006406)
SXX (administrator)
2016-02-04 15:53

Likely.
(0006449)
SXX (administrator)
2016-02-25 03:27

So problem occur because VCAI use check CQuest::checkQuest while code for border guard visits can only be found in CGBorderGuard::checkQuest.

Also there is quest type of CQuest::MISSION_KEYMASTER, but it's not really implemented so quest type of border guard is MISSION_NONE. In the end this cause infinite loop since AI thinking it's possible to "open" that tile when it's not.
(0006450)
SXX (administrator)
2016-02-25 05:55

So I fixed this one:
https://github.com/vcmi/vcmi/commit/4f7664926ead65d57a3591ee2f0cd310d5edfb84 [^]

It's would be much better to implement quest usage for CGKeys, but it's not that easy as quest system isn't finished really to do that.
(0006453)
Warmonger (administrator)
2016-02-25 06:30

That's a good explanation, but I can't see anything in the commit that would fix it?
(0006456)
Warmonger (administrator)
2016-02-25 10:45

Ahh here is the correct link: https://github.com/vcmi/vcmi/commit/57780828426778b4a1c81aa3b1f71f5147fdae03 [^]
(0006457)
SXX (administrator)
2016-02-25 12:33

Oops! Thanks!

- Issue History
Date Modified Username Field Change
2013-11-17 13:50 Povelitel New Issue
2013-11-17 13:50 Povelitel Status new => assigned
2013-11-17 13:50 Povelitel Assigned To => Tow
2013-11-17 13:50 Povelitel File Added: border guard.rar
2013-12-21 20:48 Warmonger Assigned To Tow => Warmonger
2013-12-21 20:50 Warmonger Note Added: 0004196
2013-12-21 21:33 Warmonger Note Added: 0004197
2013-12-21 21:33 Warmonger Status assigned => resolved
2013-12-21 21:33 Warmonger Fixed in Version => 0.94b
2013-12-21 21:33 Warmonger Resolution open => fixed
2014-06-01 20:09 Kantor Note Added: 0004696
2014-06-01 20:10 Kantor File Added: testowanie mantisa.h3m
2014-06-01 20:12 Kantor Note Added: 0004697
2014-06-01 20:12 Kantor Status resolved => feedback
2014-06-01 20:12 Kantor Resolution fixed => reopened
2016-01-31 19:25 SXX Assigned To Warmonger => SXX
2016-01-31 19:25 SXX Status feedback => assigned
2016-01-31 19:26 SXX Relationship added related to 0002374
2016-02-04 13:50 Povelitel Note Added: 0006404
2016-02-04 15:53 SXX Note Added: 0006406
2016-02-04 15:53 SXX Relationship added related to 0002096
2016-02-25 03:17 SXX Relationship added related to 0002383
2016-02-25 03:21 SXX Relationship added has duplicate 0002326
2016-02-25 03:23 SXX Relationship deleted related to 0002096
2016-02-25 03:23 SXX Relationship added has duplicate 0002096
2016-02-25 03:27 SXX Note Added: 0006449
2016-02-25 05:55 SXX Note Added: 0006450
2016-02-25 05:55 SXX Status assigned => resolved
2016-02-25 05:55 SXX Fixed in Version 0.94b => 0.98g
2016-02-25 05:55 SXX Resolution reopened => fixed
2016-02-25 05:56 SXX Relationship deleted has duplicate 0002326
2016-02-25 05:56 SXX Relationship added related to 0002326
2016-02-25 06:30 Warmonger Note Added: 0006453
2016-02-25 10:45 Warmonger Note Added: 0006456
2016-02-25 12:33 SXX Note Added: 0006457
2016-04-07 13:37 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean