MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000146VCMIMechanics - Battlespublic2009-10-12 21:032009-12-23 00:42
Reporteranonymous 
Assigned ToTow dragon 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.74 
Target VersionFixed in Version0.75 
Summary0000146: System message: Server encountered a problem: catapult tried to attack non-catapultable hex!
DescriptionMap: Adventures of Jared Hared



This happens when you attack first fort in map... [EDIT: The reporter must have been playing a previously saved game, as the first town on that map has no fort. See also report 0000090]



System message: Server encountered a problem: catapult tried to attack non-catapultable hex!



After that game blocks... [EDIT: The yellow glow animation still works around the first creature to act, but we cannot move it]
TagsNo tags attached.
Attached Files? file icon  VCMI_Tests.h3m [^] (10,412 bytes) 2009-10-13 23:03

- Relationships

-  Notes
(0000103)
Zamolxis (viewer)
2009-10-13 23:09

I've attached a map to easily reproduce the bug. It seems to be caused by the fact that towns w/o fort, still have the fort walls when we attack them.

This may be related also to report 0000090 - Towns w/o fort appearing as towns with fort on AdvMap after loading a saved game.
(0000115)
Tow dragon (viewer)
2009-10-17 14:00

fixed: no-fort town no longer has walls, siege with no-fort town does not give catapult
(0000475)
Zamolxis (viewer)
2009-12-23 00:42

Verified as fixed in 0.75

- Issue History
Date Modified Username Field Change
2009-10-12 21:03 anonymous New Issue
2009-10-13 23:03 Zamolxis File Added: VCMI_Tests.h3m
2009-10-13 23:09 Zamolxis Note Added: 0000103
2009-10-13 23:18 Zamolxis Severity block => crash
2009-10-13 23:21 Zamolxis Description Updated View Revisions
2009-10-13 23:25 Zamolxis Description Updated View Revisions
2009-10-13 23:26 Zamolxis Description Updated View Revisions
2009-10-17 14:00 Tow dragon Note Added: 0000115
2009-10-17 14:00 Tow dragon Status assigned => resolved
2009-10-17 14:00 Tow dragon Resolution open => fixed
2009-12-01 21:57 Tow Fixed in Version => 0.75
2009-12-23 00:42 Zamolxis Note Added: 0000475
2009-12-23 00:42 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean