MantisBT - VCMI
View Issue Details
0000146VCMIMechanics - Battlespublic2009-10-12 21:032009-12-23 00:42
Tow dragon 
0000146: System message: Server encountered a problem: catapult tried to attack non-catapultable hex!
Map: Adventures of Jared Hared

This happens when you attack first fort in map... [EDIT: The reporter must have been playing a previously saved game, as the first town on that map has no fort. See also report 0000090]

System message: Server encountered a problem: catapult tried to attack non-catapultable hex!

After that game blocks... [EDIT: The yellow glow animation still works around the first creature to act, but we cannot move it]
No tags attached.
?  VCMI_Tests.h3m (10,412) 2009-10-13 23:03
Issue History
2009-10-12 21:03anonymousNew Issue
2009-10-13 23:03ZamolxisFile Added: VCMI_Tests.h3m
2009-10-13 23:09ZamolxisNote Added: 0000103
2009-10-13 23:18ZamolxisSeverityblock => crash
2009-10-13 23:21ZamolxisDescription Updatedbug_revision_view_page.php?rev_id=213#r213
2009-10-13 23:25ZamolxisDescription Updatedbug_revision_view_page.php?rev_id=214#r214
2009-10-13 23:26ZamolxisDescription Updatedbug_revision_view_page.php?rev_id=215#r215
2009-10-17 14:00Tow dragonNote Added: 0000115
2009-10-17 14:00Tow dragonStatusassigned => resolved
2009-10-17 14:00Tow dragonResolutionopen => fixed
2009-12-01 21:57TowFixed in Version => 0.75
2009-12-23 00:42ZamolxisNote Added: 0000475
2009-12-23 00:42ZamolxisStatusresolved => closed

2009-10-13 23:09   
I've attached a map to easily reproduce the bug. It seems to be caused by the fact that towns w/o fort, still have the fort walls when we attack them.

This may be related also to report 0000090 - Towns w/o fort appearing as towns with fort on AdvMap after loading a saved game.
Tow dragon   
2009-10-17 14:00   
fixed: no-fort town no longer has walls, siege with no-fort town does not give catapult
2009-12-23 00:42   
Verified as fixed in 0.75