MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001359VCMIMechanics - Battlespublic2013-07-18 16:562016-11-11 08:26
ReporterIvan 
Assigned ToAVS 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.93 
Target VersionFixed in Version0.98d 
Summary0001359: Incorrect turn order in battle, related to Basilisks petrification
DescriptionSee video: http://www.youtube.com/watch?v=s2i07lPNjOE [^]
Around 35 second you will see this:

Vampires fly across all field
<end turn>
Vampires attack Basilisks
Basilisks attack
Basilisks turn Vampires in stone
Basilisks turn Vampires in stone
<end turn>
After this Vampires lose 2 turns despite being constantly attacked.

Not sure exactly what happens but
1) Disabled (e.g. petrified) creatures should be able to act when they lose disabling effect
2) Petrification should be removed on attack
TagsNo tags attached.
Attached Files

- Relationships
related to 0000528resolvedAVS Blind spell implemented incorrectly 
related to 0001390closedAVS Crash in creaure window after multiple Blind / Stone gaze casts 
related to 0001365closedAVS Issues with creature abilities duration. At least Unicorn's Blind and Dendroid's Roots are broken 
child of 0002185closedAVS Bonus system: incorrect usage of CBonusSystemNode::bonuses 

-  Notes
(0003822)
Ivan (developer)
2013-07-30 18:24

More fun: two battles of vyvern monarchs vs vampire lords. Sounds very similar to this one.
http://youtu.be/t9MqZCSTgvo [^]
http://youtu.be/t_IoDp2LxY8 [^]
(0003824)
Warmonger (administrator)
2013-07-31 19:36
edited on: 2013-07-31 19:39

It's funny indeed, why do Wyverns petrify?

EDIT: Fixed that part, at least.

(0003825)
Warmonger (administrator)
2013-07-31 19:57

I'm still not sure if it's even a bug. It should be possible to petrify stack two times in a row. Probably with working petrify animation it would feel different.
(0003826)
Ivan (developer)
2013-07-31 20:21

But to skip turn completely petrification must happen on every attack. two such rounds with 3 stack of basilisks = 6 attacks and each of these must petrify vampires. That's *almost* impossible.


BTW - console says about petrification correctly. And there is at least one round where there was no petrification but nevertheless vampires have not acted (around 44-46 seconds - hard to notice due to fast animation).
(0003827)
Ivan (developer)
2013-07-31 22:06

Managed to reproduce this. It seems that petrification is NOT removed on attack.
(0003830)
Warmonger (administrator)
2013-08-01 07:05
edited on: 2013-08-01 07:09

Well, this one is a real puzzle related to Bonus System. Described in detail in 0001390.

Will wait for Tow to explain what it's all about and what for.

(0005856)
AVS (administrator)
2015-09-14 15:58

Problem with removing bonuses with "duration mask" has been already fixed.

- Issue History
Date Modified Username Field Change
2013-07-18 16:56 Ivan New Issue
2013-07-18 16:57 Warmonger Assigned To => Warmonger
2013-07-18 16:57 Warmonger Status new => assigned
2013-07-25 21:49 Warmonger Relationship added related to 0000528
2013-07-30 18:24 Ivan Note Added: 0003822
2013-07-31 19:36 Warmonger Note Added: 0003824
2013-07-31 19:39 Warmonger Note Edited: 0003824 View Revisions
2013-07-31 19:57 Warmonger Note Added: 0003825
2013-07-31 19:58 Warmonger Status assigned => acknowledged
2013-07-31 20:21 Ivan Note Added: 0003826
2013-07-31 22:06 Ivan Note Added: 0003827
2013-08-01 07:03 Warmonger Relationship added related to 0001390
2013-08-01 07:05 Warmonger Note Added: 0003830
2013-08-01 07:09 Warmonger Note Edited: 0003830 View Revisions
2013-08-01 07:27 Warmonger Relationship added related to 0001365
2015-04-13 05:00 AVS Relationship added child of 0002185
2015-09-14 15:58 AVS Note Added: 0005856
2015-09-14 15:59 AVS Status acknowledged => resolved
2015-09-14 15:59 AVS Fixed in Version => 0.98d
2015-09-14 15:59 AVS Resolution open => fixed
2015-09-14 15:59 AVS Assigned To Warmonger => AVS
2016-11-11 08:26 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean