MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001063VCMIMechanics - Otherpublic2012-08-31 21:582014-05-30 17:43
ReporterZamolxis 
Assigned ToTow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.89 
Target VersionFixed in Version0.93 
Summary0001063: Visiting the Crypt at end of the movement leads to issues: second visit, crash
DescriptionSo far, this is the only way I can reproduce this:
- take Ivor in the attached map and go south-east on the road just before FoW, then the underground gate
- attack halflings, but let them flee (otherwise the bug doesn't occur - so bug could be battle/experience related also)
- attack nearest Crypt on the upper row (should be reachable with last move)
- win the battle, take the skill, but then, instead of reward, you're asked if you want to attack again
- go for the battle: before battle starts, you finally get the gold/artifact reward from defeating the Crypt, then battle screen really opens, but with no enemies
- you need to make a move which will "win" you the battle, and then we get the crash

This only happens if you reach the Crypt at the end of the movement that day. If you end turn before reaching that Crypt, the bug will not happen. So I remain puzzled whether it's related to end of movement or battles (either Ivor with Halflings, or battles of other heroes at the passing of the turn).
Additional InformationTo make checks/reproducing easier, I attached archive containing:
- save game just after Ivor entered underground
- logs & crashdump
TagsNo tags attached.
Attached Files? file icon VCMI_Tests_2012.h3m [^] (19,348 bytes) 2012-08-31 21:58
jpg file icon 2012-03-10_CryptDoubleAttackEnd.jpg [^] (292,883 bytes) 2012-08-31 21:59


7z file icon 2012-03-10_CryptDoubleAttack.7z [^] (157,162 bytes) 2012-08-31 22:05

- Relationships
duplicate of 0001053closedTow Battle continues after AI clears Bank 

-  Notes
(0003346)
Tow dragon (viewer)
2013-01-31 18:59

Interesting bug. Still reproducible with 0.9c, seems to be related to advmap object handling. The second crypt in row in reachable too but does not cause the bug.
(0003491)
Tow (developer)
2013-04-20 11:38

Fixed in r3336.

- Issue History
Date Modified Username Field Change
2012-08-31 21:58 Zamolxis New Issue
2012-08-31 21:58 Zamolxis File Added: VCMI_Tests_2012.h3m
2012-08-31 21:59 Zamolxis File Added: 2012-03-10_CryptDoubleAttackEnd.jpg
2012-08-31 22:05 Zamolxis File Added: 2012-03-10_CryptDoubleAttack.7z
2012-08-31 22:10 Zamolxis Additional Information Updated View Revisions
2013-01-28 14:16 Warmonger Relationship added duplicate of 0001053
2013-01-31 18:59 Tow dragon Note Added: 0003346
2013-04-20 11:38 Tow Note Added: 0003491
2013-04-20 11:38 Tow Status new => resolved
2013-04-20 11:38 Tow Fixed in Version => 0.93
2013-04-20 11:38 Tow Resolution open => fixed
2013-04-20 11:38 Tow Assigned To => Tow
2014-05-30 17:43 beegee Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean