MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000984VCMIGUI - Adventure Mappublic2012-05-30 13:252016-01-17 12:37
Reporterench0 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platformi386OSGNU/LinuxOS VersionFedora15Lovelock
Product Version0.88b 
Target VersionFixed in Version0.97c 
Summary0000984: Hero move on adv. map should be interruptible
DescriptionOnce you send your hero somewhere on the adventure map there is no way to stop the hero's movement, not until he/she reaches the destination.

In the original game clicking or pressing a key would stop the hero movement and the player could then send him to some other place.
Steps To Reproduceselect hero, send them to some visible location on the adventure map, click a mouse while they're travelling to there. The hero will not stop and you will not gain UI control UNTIL AFTER the hero had reached the original destination.
TagsNo tags attached.
Attached Files

- Relationships
related to 0002066closedSXX First hero movement after town / non-pickable object visit can't be interrupted 

-  Notes
(0002585)
ench0 (reporter)
2012-05-31 11:50

This seems to be more of a timing issue rather than unimplemented feature - it happens SOMETIMES, on shorter routes.
I originally reported it with "Reproducibility - always" which is wrong... my apologies.
(0005441)
SXX (administrator)
2015-02-10 22:13

I think this old issue need to be marked as "resolved" because sometimes ago there was change made so each time hero movement occur server have to get confirmation for movement from client.

It's what @AVS told me about and it's work pretty good now except there is one specific issue where it's not work as excepted. Though it's not likely related to VCMI state in 2012 so I posted it as new issue 0002066
(0005610)
SXX (administrator)
2015-03-10 18:56

Should be now fixed completely. More details available there: 0002066

- Issue History
Date Modified Username Field Change
2012-05-30 13:25 ench0 New Issue
2012-05-31 11:50 ench0 Note Added: 0002585
2012-06-02 13:34 Ivan Reproducibility always => sometimes
2015-02-10 22:02 SXX Relationship added related to 0002066
2015-02-10 22:13 SXX Note Added: 0005441
2015-03-01 13:39 SXX Assigned To => SXX
2015-03-01 13:39 SXX Status new => assigned
2015-03-10 18:56 SXX Note Added: 0005610
2015-03-10 18:56 SXX Status assigned => resolved
2015-03-10 18:56 SXX Fixed in Version => 0.97c
2015-03-10 18:56 SXX Resolution open => fixed
2016-01-17 12:37 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean