MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000098VCMIGUI - Otherpublic2009-10-04 12:272012-09-28 07:12
ReporterTow dragon 
Assigned ToIvan 
PrioritynormalSeveritytweakReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.73 
Target VersionFixed in Version0.88 
Summary0000098: No info in status window if you collect guarded resources.
Description0.73#64 - No info in status window if you collect guarded resources.

EDIT: We also hear the sound of collecting the resource in the moment the battle is won, before we close the window with battle casualties. Instead the game should wait that we close that window, and only then play the sound and give into about the collected resource in the status window.
Additional InformationOriginally reported here: http://forum.vcmi.eu/viewtopic.php?p=3288#3288 [^]
TagsNo tags attached.
Attached Filesdiff file icon bug_0000098.diff [^] (421 bytes) 2012-01-10 21:39 [Show Content]

- Relationships

-  Notes
(0000134)
Zamolxis (viewer)
2009-10-18 23:12

I'm not sure if Boulie (who reported this) or sb else can clarify this bug:
- does "status window" refer to the InfoBox in the lower right corner of the Adventure Map?
- are "guarded resources" just resource piles next to a monster? If yes, do we have a different message for those (though I'm pretty sure I'm missing sth here)?
(0000135)
Ivan (developer)
2009-10-19 10:42

- Yes. Status window refer to InfoBox
- No. This is resource piles with guards "inside" (like events with guardians)
(0000136)
beholder (reporter)
2009-10-19 16:24

Was there any info at all??
(0000137)
Zamolxis (viewer)
2009-10-19 19:43
edited on: 2011-09-20 13:55

@Ivan: Thanks for the clarification. Description updated and report marked as acknowledged.

***

[off-topic]

@beholder: As far as "info" about the surprise attack from the resource guardian(s) indeed, there wasn't any, UNLESS customized from MapEd. It was only Pandora's Box that was giving a message by default ("You should have known better - you are attacked!), following the dialogue giving you the choice to open it or not. But nothing similar for resources (at least not in my version of H3C).

However while testing this, I found a new issue (see report 0000183).

I do find it interesting though, that H3 implemented this as such, that if you don't customize the message, you are attacked by surprise, while if there is a message, then you get the chance to avoid the battle. Maybe it was intended as a feature, giving Map Editors the choice to give the player the chance to avoid the battle, or force him into it (when no custom message). But personally I still see it as a bug and would prefer if we could put in place a default message for when the map maker didn't prepare one from the editor.

(0002154)
cipone23 (reporter)
2012-01-10 21:40

Tow Dragon answered me in a PM on the forum, telling me I can take care of this for starters. Reproduced the bug on "VCMI tests 2011 b" , Aislinn getting the guarded upper left gold resource.

It turned out that ShowComp in CPlayerInterface needed a waitWhileDialog() ( I thought of adding "Closes" to the method name but I passed this time :-) ). Here's the patch.
(0002183)
Ivan (developer)
2012-02-18 15:28

Patch applied in rev 2533
(0003057)
Zamolxis (viewer)
2012-09-28 06:24

Checked in 0.89 and confirmed as fixed

- Issue History
Date Modified Username Field Change
2009-10-04 12:27 Tow dragon New Issue
2009-10-18 23:12 Zamolxis Note Added: 0000134
2009-10-18 23:12 Zamolxis Description Updated View Revisions
2009-10-19 10:42 Ivan Note Added: 0000135
2009-10-19 16:24 beholder Note Added: 0000136
2009-10-19 19:43 Zamolxis Note Added: 0000137
2009-10-19 19:51 Zamolxis Note Edited: 0000137 View Revisions
2010-05-29 21:27 Zamolxis Product Version => 0.73
2010-05-30 12:13 Zamolxis Status new => confirmed
2010-05-30 12:13 Zamolxis Description Updated View Revisions
2010-05-30 12:13 Zamolxis Severity text => tweak
2010-11-20 23:26 Zamolxis Note Edited: 0000137 View Revisions
2011-09-20 13:55 Zamolxis Note Edited: 0000137 View Revisions
2011-09-20 13:55 Zamolxis Status confirmed => acknowledged
2011-09-20 13:56 Zamolxis Priority low => normal
2011-09-20 14:03 Warmonger Status acknowledged => assigned
2011-09-20 14:03 Warmonger Assigned To => Warmonger
2012-01-10 21:39 cipone23 File Added: bug_0000098.diff
2012-01-10 21:40 cipone23 Note Added: 0002154
2012-02-18 15:28 Ivan Note Added: 0002183
2012-02-18 15:28 Ivan Status assigned => resolved
2012-02-18 15:28 Ivan Fixed in Version => 0.89
2012-02-18 15:28 Ivan Resolution open => fixed
2012-02-18 15:28 Ivan Assigned To Warmonger => Ivan
2012-09-28 06:24 Zamolxis Note Added: 0003057
2012-09-28 06:24 Zamolxis Status resolved => closed
2012-09-28 07:12 Zamolxis Issue cloned: 0001090

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2022 MantisBT Team
Hosting provided by DigitalOcean