MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000912VCMIMechanics - Battlespublic2012-03-13 08:072014-05-30 17:40
Reporterq4a 
Assigned ToTow 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP SP3
Product Version0.88 
Target VersionFixed in Version0.89 
Summary0000912: Crash on 2nd turn of battle with Dungeon town
DescriptionTested on r2589.
Attached file contain save game and full client+server log.

VCMI_Client_log.txt:
Listening... received server message of type struct StartAction
CStupidAI [0D2EB758]: actionStarted called
    Made first apply on cl
    Applied on gs
    Made second apply on cl
Listening... received server message of type struct BattleStacksRemoved
    Made first apply on cl
Battle stack [7]: 1 creatures of Arrow Towers from slot 255 #detached from# Town (Dungeon) of Deepshadow
Battle stack [7]: 1 creatures of Arrow Towers from slot 255 #detached from# "Arrow Towers"
    Applied on gs
Wrong player id in blueToPlayersAdv (221)!
Steps To ReproduceLoad attached save game (homm3 map "Dragon Orb").
Select 2nd hero(Elleshar).
Attack Dungeon.
Battle:
Dragon-Wait.
Centaurs-Defend.
Elves-Attack Harpy.
Dwarves-Defend.
Dragon-Attack Harpy.
Then you got crash.
TagsNo tags attached.
Attached Files7z file icon save+log.7z [^] (112,010 bytes) 2012-03-13 08:07

- Relationships
related to 0000886resolvedAVS Crash after cloned creatures move 

-  Notes
(0002317)
Tow (developer)
2012-03-26 12:22

I'm not able to reproduce issue but found a scenario:
1 turret is killed by catapult
2 stack is removed from game
3 stack queue redraws, can't get info for deleted turret -> crash
4 GUI receives info about removed stack and removes it from queue

There's a race condition between 3 and 4, I'll try to fix this later, along with the Cloning issues.
(0002333)
Tow (developer)
2012-04-06 15:09

Fixed in r2611.

- Issue History
Date Modified Username Field Change
2012-03-13 08:07 q4a New Issue
2012-03-13 08:07 q4a File Added: save+log.7z
2012-03-26 12:22 Tow Note Added: 0002317
2012-03-26 12:22 Tow Assigned To => Tow
2012-03-26 12:22 Tow Status new => confirmed
2012-03-26 12:23 Tow Relationship added related to 0000886
2012-04-06 15:09 Tow Note Added: 0002333
2012-04-06 15:09 Tow Status confirmed => resolved
2012-04-06 15:09 Tow Fixed in Version => 0.89
2012-04-06 15:09 Tow Resolution open => fixed
2014-05-30 17:40 beegee Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2019 MantisBT Team
Hosting provided by DigitalOcean