MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000713VCMIGUI - Battlespublic2011-03-07 20:012014-05-30 17:40
ReporterZamolxis 
Assigned ToIvan 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.84 
Target VersionFixed in Version0.85 
Summary0000713: The R-click info boxes for the 'Default' and 'Return to Game' buttons in Combat Options window are swapped.
DescriptionIf we R-click on the 'Default' or 'Return to Game' buttons in the Combat Options window, we get the info box of the other one.
Additional InformationAlso, the info boxes pop up above the button, not centered. But this should probably be handled together with 0000705 as it's valid for all info boxes that open at R-click in this window.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000712closedIvan Various items in the Combat Options window are buggy or don't work at all anymore since 0.84 (similar for System Options) 
related to 0000705new Info boxes in Hero screen pop up above the object we R-click on i/o the center of the window 

-  Notes
(0001720)
Tow (developer)
2011-05-25 15:16

It's due to changes in button system, some buttons have only 2 or 3 frames and then the last frame is to be used for HIGHLIGHTED state. Current code requires image to have 4 frames for highlightable buttons, breaking some of them.
(0001723)
Tow (developer)
2011-05-25 22:49

Sorry, ignore the comment above, it was meant for 0000712.
(0001729)
Ivan (developer)
2011-05-28 10:09

Message text is fixed in rev 2153

- Issue History
Date Modified Username Field Change
2011-03-07 20:01 Zamolxis New Issue
2011-03-07 20:01 Zamolxis Status new => assigned
2011-03-07 20:01 Zamolxis Assigned To => Tow dragon
2011-03-07 20:01 Zamolxis Issue generated from: 0000712
2011-03-07 20:01 Zamolxis Relationship added related to 0000712
2011-03-07 20:01 Zamolxis Relationship added related to 0000705
2011-05-25 15:16 Tow Note Added: 0001720
2011-05-25 15:16 Tow Assigned To Tow dragon => Ivan
2011-05-25 22:49 Tow Note Added: 0001723
2011-05-28 10:09 Ivan Note Added: 0001729
2011-05-28 10:09 Ivan Status assigned => resolved
2011-05-28 10:09 Ivan Fixed in Version => 0.89
2011-05-28 10:09 Ivan Resolution open => fixed
2014-05-30 17:40 beegee Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2021 MantisBT Team
Hosting provided by DigitalOcean