MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000531VCMIGUI - Town screenpublic2010-07-13 11:302014-05-30 17:41
ReporterZamolxis 
Assigned ToIvan 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD 5600+OSWindowsOS VersionXP SP3
Product Version0.81 
Target VersionFixed in Version0.9 
Summary0000531: "There is not enough room in the garrison" message missing in the Town Screen
DescriptionIt should be displayed when we try to move a hero from town gate to garrison and there are 8 or more stacks in the 14 slots (split stacks not considered, as they should merge if necessary).
TagsNo tags attached.
Attached Filespng file icon Screenshot - 07222012 - 05:39:26 AM.png [^] (1,057,093 bytes) 2012-07-22 09:44

- Relationships
related to 0000229closedTow Bug stack disappears during hidding hero into garrison if the garrison is full 

-  Notes
(0002817)
Ivan (developer)
2012-07-21 20:17

fixed in rev 2799
(0002819)
douggie_m (reporter)
2012-07-21 21:18
edited on: 2012-07-21 21:39

Will check :3

UPD: Hmm?... Build error!

make[3]: Entering directory `/home/username/Development/VCMI/vcmi-svn/AI/VCAI'
  CXX libVCAI_la-main.lo
  CXX libVCAI_la-VCAI.lo
VCAI.cpp: In member function 'void VCAI::striveToQuest(const QuestInfo&)':
VCAI.cpp:2119:44: error: 'PRISON' is not a member of 'Obj'
make[3]: *** [libVCAI_la-VCAI.lo] Error 1
make[3]: Leaving directory `/home/username/Development/VCMI/vcmi-svn/AI/VCAI'
make[2]: *** [all] Error 2

(0002820)
douggie_m (reporter)
2012-07-21 21:55

Build error with r2799. Feedback required.
(0002821)
Ivan (developer)
2012-07-22 07:32

Looks like some kind of incomplete update:
AI/VCAI/VCAI.cpp is in latest revision (after Obj::PRISON was added in rev 2798)
lib/GameConstants.h is still not updated (without Obj::PRISON -> before 2798)
(0002822)
douggie_m (reporter)
2012-07-22 09:43

Ah, it looks like SVN issue. Fresh checkout has no such problem.

"There is not enough room in the garrison" is shown now. Also, the following is printed to stdout:

Cannot wait for dialogs in gui thread (deadlock risk)!

- Issue History
Date Modified Username Field Change
2010-07-13 11:30 Zamolxis New Issue
2010-07-13 11:30 Zamolxis Issue generated from: 0000229
2010-07-13 11:30 Zamolxis Relationship added related to 0000229
2011-10-18 06:36 yupsi Status new => assigned
2011-10-18 06:36 yupsi Assigned To => yupsi
2011-10-18 11:50 Warmonger Category Mechanics - Other => GUI - Town screen
2012-07-20 17:38 Ivan Assigned To yupsi => Ivan
2012-07-21 20:17 Ivan Note Added: 0002817
2012-07-21 20:17 Ivan Status assigned => resolved
2012-07-21 20:17 Ivan Fixed in Version => 0.9
2012-07-21 20:17 Ivan Resolution open => fixed
2012-07-21 21:18 douggie_m Note Added: 0002819
2012-07-21 21:39 douggie_m Note Edited: 0002819 View Revisions
2012-07-21 21:55 douggie_m Note Added: 0002820
2012-07-21 21:55 douggie_m Status resolved => feedback
2012-07-21 21:55 douggie_m Resolution fixed => reopened
2012-07-22 07:32 Ivan Note Added: 0002821
2012-07-22 09:43 douggie_m Note Added: 0002822
2012-07-22 09:44 douggie_m File Added: Screenshot - 07222012 - 05:39:26 AM.png
2012-07-22 10:05 Warmonger Status feedback => resolved
2012-07-22 10:05 Warmonger Resolution reopened => fixed
2014-05-30 17:41 beegee Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2022 MantisBT Team
Hosting provided by DigitalOcean