MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000522VCMIGUI - Adventure Mappublic2010-07-09 10:302010-11-22 12:18
ReporterBoulie 
Assigned ToTow 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product Version0.81 
Target VersionFixed in Version0.82 
Summary0000522: Graphic glitches/heroes interface freeze if turn is ended after save game during blue player turn
DescriptionSo bug 0000443 seems to be not resolved.
Added force crashdump files and save
Steps To ReproduceLoad saved game and end turn. If it won't cause the VCMI is hanged, end red player turn, make a save during blue player turn and end turn just after it. I hope it will cause the interface is frozen.
TagsNo tags attached.
Attached Filesjpg file icon blue player screen is freezed after end turn_01.jpg [^] (556,253 bytes) 2010-07-09 10:30


jpg file icon blue player screen is freezed after end turn_02.jpg [^] (496,399 bytes) 2010-07-09 10:30


jpg file icon blue player screen is freezed after end turn_03.jpg [^] (97,770 bytes) 2010-07-09 10:30


zip file icon games blue player turn.zip [^] (187,708 bytes) 2010-07-09 10:31
zip file icon forced crash after blue player ends turn and game freeze_01.zip [^] (140,168 bytes) 2010-07-09 10:31
zip file icon forced crash after blue player ends turn and game freeze_02.zip [^] (142,433 bytes) 2010-07-09 10:31
zip file icon games MP red turn.zip [^] (187,582 bytes) 2010-07-09 13:33
jpg file icon new nice screen 1680x1050.jpg [^] (731,041 bytes) 2010-07-12 13:22


jpg file icon new nice screen 1680x1050_02.jpg [^] (841,261 bytes) 2010-07-12 13:25


jpg file icon 082 interface freezes.jpg [^] (249,409 bytes) 2010-08-05 13:44


zip file icon 082 interface freezes_games.zip [^] (318,015 bytes) 2010-08-05 13:49
zip file icon 082 interface freezes_logs.zip [^] (139,339 bytes) 2010-08-05 13:50
jpg file icon crash after ending the turn.jpg [^] (204,009 bytes) 2010-08-05 13:58


zip file icon crash after ending the turn.zip [^] (155,044 bytes) 2010-08-05 13:58

- Relationships
related to 0000443closedTow Bug / crash after interface freezes if the blue player turn was ended after saving the game 

-  Notes
(0001048)
Boulie (reporter)
2010-07-09 13:33

there is even no need to make a save. It is enough to end turn of blue player.
Added one more save from red turn. Just end his turn and end blue player turn. It works always on my laptop.
(0001162)
Tow (developer)
2010-07-24 11:50

It may be fixed in r1688, I'm not sure, since it was not so easily reproducible for me (race condition bug). Please check if issue is really fixed in the upcoming dev build.
(0001290)
Boulie (reporter)
2010-08-05 13:42
edited on: 2010-08-05 13:58

This problem still exist in 0,82
Probably related to 0000556 (http://bugs.vcmi.eu/view.php?id=556 [^])

EDIT:
Seems that it is also related with going back to main menu. I've added new save.
Start VCMI, load it, you can end turn (should be ok), but go to main menu, load it again and then end turn - now the interface should be crashed.

EDIT2: Unfortunatly it is not always reproducible.
But I've just got crash during testing this problem. (added screenshot and logs)


- Issue History
Date Modified Username Field Change
2010-07-09 10:30 Boulie New Issue
2010-07-09 10:30 Boulie File Added: blue player screen is freezed after end turn_01.jpg
2010-07-09 10:30 Boulie File Added: blue player screen is freezed after end turn_02.jpg
2010-07-09 10:30 Boulie File Added: blue player screen is freezed after end turn_03.jpg
2010-07-09 10:31 Boulie File Added: games blue player turn.zip
2010-07-09 10:31 Boulie File Added: forced crash after blue player ends turn and game freeze_01.zip
2010-07-09 10:31 Boulie File Added: forced crash after blue player ends turn and game freeze_02.zip
2010-07-09 13:33 Boulie Note Added: 0001048
2010-07-09 13:33 Boulie File Added: games MP red turn.zip
2010-07-09 14:25 Zamolxis Relationship added related to 0000443
2010-07-12 13:22 Boulie File Added: new nice screen 1680x1050.jpg
2010-07-12 13:25 Boulie File Added: new nice screen 1680x1050_02.jpg
2010-07-24 11:50 Tow Note Added: 0001162
2010-07-24 11:50 Tow Status new => resolved
2010-07-24 11:50 Tow Fixed in Version => 0.89
2010-07-24 11:50 Tow Resolution open => fixed
2010-07-24 11:50 Tow Assigned To => Tow
2010-07-24 11:58 Zamolxis Product Version => 0.81
2010-08-05 13:42 Boulie Note Added: 0001290
2010-08-05 13:42 Boulie Status resolved => feedback
2010-08-05 13:42 Boulie Resolution fixed => reopened
2010-08-05 13:43 Boulie Note Edited: 0001290 View Revisions
2010-08-05 13:44 Boulie File Added: 082 interface freezes.jpg
2010-08-05 13:49 Boulie Note Edited: 0001290 View Revisions
2010-08-05 13:49 Boulie File Added: 082 interface freezes_games.zip
2010-08-05 13:50 Boulie File Added: 082 interface freezes_logs.zip
2010-08-05 13:58 Boulie Note Edited: 0001290 View Revisions
2010-08-05 13:58 Boulie File Added: crash after ending the turn.jpg
2010-08-05 13:58 Boulie File Added: crash after ending the turn.zip
2010-11-22 12:18 Zamolxis Priority high => normal

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean