MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000350VCMIMechanics - Objectspublic2010-02-11 23:002010-05-29 20:22
ReporterZamolxis 
Assigned ToTow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.75 
Target VersionFixed in Version0.8 
Summary0000350: Subterranean Gate is requesting movement points from the hero, to pass to the other side.
DescriptionWhile this may be the subject of a balancing tweak if we want, it's not OH3 behavior, where you could peak as much as you wanted on both sides of the gate. :)



See screenshot attached to 0000349. To reproduce, take Ivor in the attached map and go East (behind the green hero).
Additional InformationWhat I noticed however when trying to reproduce 0000351 in 0.75, is that in case we do have movement points left, then we can actually go as much as we want from one side of the gate to the other. So it means VCMI is not using MP, but just apparently requests them in case we reach the Gate with our last move (like it would expect the hero to have MP left to go through the gate, but actually not costing him any of those MP).
TagsNo tags attached.
Attached Files? file icon  VCMI_Tests.h3m [^] (11,986 bytes) 2010-02-11 23:00

- Relationships
related to 0000351closedTow Crash when moving hero through the Subterranean Gate 
child of 0000336closedTow When hero reach monolith with no movement points left you can't go throught it 

-  Notes
(0000633)
Tow (developer)
2010-02-12 07:50

Duplicate to 0000336 actually.
Fixed in r1481 anyway.
(0000644)
Zamolxis (viewer)
2010-02-12 18:34

I didn't think of using "monolith" as search word when I looked for the report of a similar bug. :p

- Issue History
Date Modified Username Field Change
2010-02-11 23:00 Zamolxis New Issue
2010-02-11 23:00 Zamolxis File Added: VCMI_Tests.h3m
2010-02-11 23:19 Zamolxis Issue cloned: 0000351
2010-02-11 23:20 Zamolxis Relationship added related to 0000351
2010-02-11 23:41 Zamolxis Additional Information Updated View Revisions
2010-02-12 07:50 Tow Note Added: 0000633
2010-02-12 07:50 Tow Status assigned => closed
2010-02-12 07:50 Tow Resolution open => duplicate
2010-02-12 07:50 Tow Relationship added duplicate of 0000336
2010-02-12 18:34 Zamolxis Note Added: 0000644
2010-02-13 00:41 Zamolxis Relationship replaced child of 0000336
2010-05-29 20:19 Zamolxis Status closed => new
2010-05-29 20:20 Zamolxis Relationship deleted child of 0000336
2010-05-29 20:20 Zamolxis Relationship added child of 0000336
2010-05-29 20:21 Zamolxis Status new => assigned
2010-05-29 20:21 Zamolxis Resolution duplicate => fixed
2010-05-29 20:21 Zamolxis Status assigned => resolved
2010-05-29 20:21 Zamolxis Fixed in Version => 0.8
2010-05-29 20:22 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2023 MantisBT Team
Hosting provided by DigitalOcean