MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002698VCMILauncherpublic2017-06-19 12:292021-01-26 10:57
Reporterdracomagister 
Assigned ToSXX 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionnot fixable 
PlatformLinuxOSLinux MintOS Version17.1 Rebecca
Product Version0.next 
Target VersionFixed in Version 
Summary0002698: [Linux / Ubuntu] vcmibuilder don't work with the current GOG installer
DescriptionWhen trying to use vcmibuilder, I get the following:

warning: unexpected setup data version: 5.5.7 (unicode)
warning: unexpected Auto Boolean value: 20
warning: unexpected Architecture flags: 10
warning: unexpected data while converting from CP1200 to UTF-8
stream error: basic_ios::clear
Done with 1 error and 4 warnings.
Steps To ReproduceDownload the last GOG installer (4.0) and run

vcmibuilder --gog /path_to_the/installer.exe
Additional InformationI have all dependencies required and it works without problem with the previous installer.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007160)
SXX (administrator)
2017-07-22 14:08

I suppose this is problem with older innoextract version present in Ubuntu 14.04.
I tried to unpack latest installer on Kubuntu 17.04 and it's working fine:
./vcmibuilder --gog /mnt/datanew/Heroes\ of\ Might\ and\ Magic\ III\ Complete\ GOG/setup_homm_3_complete_4.0_\(10665\).exe
(0007386)
SXX (administrator)
2018-01-28 05:03

Nice guy @paulsetchko added version check:
https://github.com/vcmi/vcmi/pull/408 [^]

Unfortunately there nothing else we can do.

- Issue History
Date Modified Username Field Change
2017-06-19 12:29 dracomagister New Issue
2017-07-22 14:03 SXX Assigned To => SXX
2017-07-22 14:03 SXX Status new => assigned
2017-07-22 14:08 SXX Note Added: 0007160
2017-07-22 14:08 SXX Status assigned => acknowledged
2017-07-22 14:08 SXX Summary vcmibuilder don't work with the current GOG installer => vcmibuilder don't work with the current GOG installer
2018-01-28 05:03 SXX Note Added: 0007386
2021-01-26 10:57 MikeLodz Status acknowledged => resolved
2021-01-26 10:57 MikeLodz Resolution open => not fixable
2021-01-26 10:57 MikeLodz Product Version 0.99 => 0.next
2021-01-26 10:57 MikeLodz Summary vcmibuilder don't work with the current GOG installer => [Linux / Ubuntu] vcmibuilder don't work with the current GOG installer

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2021 MantisBT Team
Hosting provided by DigitalOcean