MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002685VCMIGUI - Hero screen / Exchange windowpublic2017-05-27 09:332017-05-27 15:28
Reporter0nedef 
Assigned ToAVS 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD64OSArchlinuxOS Version
Product Version 
Target VersionFixed in Version0.next 
Summary0002685: Putting on an artifact in a slot previously occupied by a combined artifact leads to crash
DescriptionRefer to "Steps to reproduce". Reproduced on develop branch head.
Steps To Reproduce* assemble Cloak of the Undead King from Amulet of the Undertaker, Vampire's Cowl and Dead Man's Boots (available on Adela hero's backpack)
* take the cloak off
* put on an artifact in a slot the assembled cloak used to take
TagsNo tags attached.
Attached Fileszip file icon asdf.zip [^] (1,049,760 bytes) 2017-05-27 09:33
txt file icon VCMI_Client_log.txt [^] (134,453 bytes) 2017-05-27 09:34 [Show Content]
txt file icon VCMI_Server_log.txt [^] (115,104 bytes) 2017-05-27 09:34 [Show Content]
? file icon valgrind.log.xz [^] (901,404 bytes) 2017-05-27 09:34
log file icon gdb.log [^] (20,379 bytes) 2017-05-27 09:34

- Relationships
duplicate of 0002538closedAVS Combined artifacts: crash on attempt to move anything on slot previously used by combined art 
related to 0002395resolvedAVS Crash when moving combined artifact 

-  Notes
(0007055)
AVS (administrator)
2017-05-27 14:09

Fixed, than you for comprehensive report.
(0007058)
0nedef (reporter)
2017-05-27 15:15

Confirmed that problem went away with current develop head.

- Issue History
Date Modified Username Field Change
2017-05-27 09:33 0nedef New Issue
2017-05-27 09:33 0nedef File Added: asdf.zip
2017-05-27 09:34 0nedef File Added: VCMI_Client_log.txt
2017-05-27 09:34 0nedef File Added: VCMI_Server_log.txt
2017-05-27 09:34 0nedef File Added: valgrind.log.xz
2017-05-27 09:34 0nedef File Added: gdb.log
2017-05-27 13:44 AVS Relationship added related to 0002395
2017-05-27 13:48 SXX Relationship added duplicate of 0002538
2017-05-27 14:09 AVS Note Added: 0007055
2017-05-27 14:09 AVS Status new => resolved
2017-05-27 14:09 AVS Fixed in Version => 0.next
2017-05-27 14:09 AVS Resolution open => fixed
2017-05-27 14:09 AVS Assigned To => AVS
2017-05-27 15:15 0nedef Note Added: 0007058
2017-05-27 15:28 AVS Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean