MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002339VCMIMechanics - Objectspublic2015-11-28 19:342016-02-17 08:38
ReporterSXX 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.98e 
Target VersionFixed in Version0.98g 
Summary0002339: Placed event: disappear after first visit even if it's marked as permanent
DescriptionImportant note about H3 behaviour: if permanent placed event have guards they disappear once killed once. So event apply every time, but guards only till killed.
TagsNo tags attached.
Attached Files? file icon EventTest.h3m [^] (4,092 bytes) 2016-02-16 21:37

- Relationships
duplicate of 0001857resolvedSXX Cannot revisit Events marked as such 

-  Notes
(0006129)
SXX (administrator)
2015-11-28 20:11

https://github.com/vcmi/vcmi/commit/ce5b7c73be320c742b4c2f0464eb7e6b911c8190 [^]
(0006429)
Kantor (updater)
2016-02-16 21:38

This one is still an issue.
(0006431)
SXX (administrator)
2016-02-17 08:16

Ok it's looks like that specific to creature set. CGEvent based on CGPandoraBox that simply pass it's own creature set so if you take creature it's no longer belong to map object.

So event is not removed, but it's simply don't have creatures to give you.

Nice catch!
(0006433)
SXX (administrator)
2016-02-17 08:38

Ok it's was a bit different problem than what I was thinking about.
Now it's fixed:
https://github.com/vcmi/vcmi/commit/07961766ca1a9461ef2b7d6d3a744ec49395cfdd [^]

- Issue History
Date Modified Username Field Change
2015-11-28 19:34 SXX New Issue
2015-11-28 19:34 SXX Status new => assigned
2015-11-28 19:34 SXX Assigned To => SXX
2015-11-28 20:11 SXX Note Added: 0006129
2015-11-28 20:11 SXX Status assigned => resolved
2015-11-28 20:11 SXX Fixed in Version => 0.98f
2015-11-28 20:11 SXX Resolution open => fixed
2015-11-28 20:14 SXX Summary Placed event disappear after first visit even if it's marked as permanent => Placed event: disappear after first visit even if it's marked as permanent
2015-12-24 12:39 SXX Relationship added duplicate of 0001857
2016-02-16 21:37 Kantor File Added: EventTest.h3m
2016-02-16 21:38 Kantor Note Added: 0006429
2016-02-16 21:38 Kantor Status resolved => feedback
2016-02-16 21:38 Kantor Resolution fixed => reopened
2016-02-17 08:11 SXX Note Added: 0006430
2016-02-17 08:11 SXX Status feedback => assigned
2016-02-17 08:11 SXX Note Deleted: 0006430
2016-02-17 08:16 SXX Note Added: 0006431
2016-02-17 08:38 SXX Note Added: 0006433
2016-02-17 08:38 SXX Status assigned => resolved
2016-02-17 08:38 SXX Fixed in Version 0.98f => 0.98g
2016-02-17 08:38 SXX Resolution reopened => fixed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean