MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002315VCMIMechanics - Otherpublic2015-10-24 19:452016-11-11 07:35
ReporterPovelitel 
Assigned ToAVS 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64OSWindowsOS VersionXP sp2
Product Version0.98d 
Target VersionFixed in Version0.99 
Summary0002315: Crash during AI turn
DescriptionStart turn teal AI and immediately CRASH.
Steps To ReproduceJust press "end turn".
Additional InformationI wanted to cheat open the entire map, and then save it, but I do not work out. Game knocked out with an error.
What I want to say - there is a bug with saving the game.
TagsNo tags attached.
Attached Filesrar file icon crashsave.rar [^] (1,103,293 bytes) 2015-10-24 19:45
txt file icon VCMI_Client_log.txt [^] (4,917,818 bytes) 2015-10-24 19:45
txt file icon VCMI_Server_log.txt [^] (1,806,627 bytes) 2015-10-24 19:46

- Relationships
duplicate of 0002314resolvedAVS Crashes related to bonus system in deserializationFix 

-  Notes
(0006005)
Warmonger (administrator)
2015-10-25 07:51

Indeed, can't load this.
(0006020)
Povelitel (updater)
2015-10-25 11:19

The same is true of the 2308 saves as I loaded ...
(0006026)
Warmonger (administrator)
2015-10-25 18:14

Another one (Purple turn).

Check for value of hero Attack causes crash.
(0006612)
SXX (administrator)
2016-09-04 08:13

Fixed by PR202. For more details or comments please check 0002314

- Issue History
Date Modified Username Field Change
2015-10-24 19:45 Povelitel New Issue
2015-10-24 19:45 Povelitel Status new => assigned
2015-10-24 19:45 Povelitel Assigned To => Warmonger
2015-10-24 19:45 Povelitel File Added: crashsave.rar
2015-10-24 19:45 Povelitel File Added: VCMI_Client_log.txt
2015-10-24 19:46 Povelitel File Added: VCMI_Server_log.txt
2015-10-25 07:51 Warmonger Note Added: 0006005
2015-10-25 11:19 Povelitel Note Added: 0006020
2015-10-25 18:13 Warmonger Relationship added related to 0002316
2015-10-25 18:14 Warmonger Note Added: 0006026
2015-10-25 18:14 Warmonger Assigned To Warmonger =>
2015-10-25 18:14 Warmonger Status assigned => new
2015-10-25 18:14 Warmonger Category AI - Adventure Map => Mechanics - Other
2015-12-25 12:15 SXX Relationship added duplicate of 0002314
2015-12-25 12:15 SXX Relationship deleted related to 0002316
2016-09-04 08:13 SXX Note Added: 0006612
2016-09-04 08:13 SXX Status new => resolved
2016-09-04 08:13 SXX Fixed in Version => 0.99
2016-09-04 08:13 SXX Resolution open => fixed
2016-09-04 08:13 SXX Assigned To => AVS
2016-11-11 07:35 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean