MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002258VCMIGUI - Hero screen / Exchange windowpublic2015-09-19 12:322016-11-11 08:26
Reporterarwer13 
Assigned ToAVS 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSArch Linux x64OS Versionupstream
Product Version0.98c 
Target VersionFixed in Version0.98d 
Summary0002258: Crash on moving a slot in garrison if slot is single
DescriptionVCMI version: git-develop.
This bug happens either in hero and town garrison, only if there are a single slot in it.

Crashes with Segmentaion Fault in line
LOCPLINT->cb->splitStack(selectedObj, owner->armedObjs[upg], selection->ID, ID, myStack->count - 1)
because myStack is nullptr in this case.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005870)
AVS (administrator)
2015-09-19 14:21

Regression of PR 115 https://github.com/vcmi/vcmi/pull/115. [^]
Fixed in https://github.com/vcmi/vcmi/commit/8cad23956c81f02c12583a022a333e34ce91c184 [^]

- Issue History
Date Modified Username Field Change
2015-09-19 12:32 arwer13 New Issue
2015-09-19 12:36 arwer13 Status new => feedback
2015-09-19 14:09 AVS Assigned To => AVS
2015-09-19 14:09 AVS Status feedback => assigned
2015-09-19 14:21 AVS Note Added: 0005870
2015-09-19 14:21 AVS Status assigned => resolved
2015-09-19 14:21 AVS Fixed in Version => 0.98d
2015-09-19 14:21 AVS Resolution open => fixed
2016-11-11 08:26 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean