MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002053VCMIGUI - Adventure Mappublic2015-02-01 18:312016-11-11 08:22
ReporterWarmonger 
Assigned ToFay 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97c 
Target Version0.97cFixed in Version0.97c 
Summary0002053: Missing def for heroes on adventure map
DescriptionAs in the screenshot, happens for all the heroes.
Additional InformationNoticed after https://github.com/vcmi/vcmi/commit/594295da3253356679e8901f55837fc299e37d15, [^] but could come from some earlier commits.
TagsNo tags attached.
Attached Filespng file icon Bug2053.png [^] (268,773 bytes) 2015-02-01 18:31

- Relationships

-  Notes
(0005404)
Fay (developer)
2015-02-01 21:39

Hmm, could it depend on OS/compiler? On my win7/mingw it works correctly.

Does it look the same during the hero movement?
Does it happen in world view mode as well?
(0005406)
SXX (administrator)
2015-02-02 00:49

When I tested Fay branch there was no such issue on Linux.
(0005407)
Warmonger (administrator)
2015-02-02 05:27

It also happens during movement and in world view.


I can see console message "Call loadBitmap with void name".
(0005408)
Fay (developer)
2015-02-02 17:01

Well, that's strange. From what I've checked, hero images are .defs and they don't use CBitmapHandler::loadBitmap (the one that prints this message) at all. Maybe it's not related (also I don't have any of these messages).

I can cause this issue (cyan bg) by changing this call https://github.com/vcmi/vcmi/blob/develop/client/mapHandler.cpp#L799 [^] to pass false as the last param (but only in world view mode, normal map still works correctly for me).
(0005426)
Warmonger (administrator)
2015-02-09 07:49
edited on: 2015-02-09 08:01

Okay, that message was related just to "world view" option:

Call to loadBitmap with void fname!
Call to loadBitmap with void fname!
Error: Failed to find file
bgWorldView not defined in resolution config; fallback to VWorld.bmp

(0005427)
Fay (developer)
2015-02-09 11:29

Yeah, this one is expected & correct as long as you don't have this value defined in resolutions.json.

Are you able to check what happens for you after changing this this call https://github.com/vcmi/vcmi/blob/develop/client/mapHandler.cpp#L799 [^] to pass false instead of true as the last param? I think this might have changed from the previous implementation (it looks like it was drawn without alpha for some reason, maybe it was the correct behavior).
(0005430)
Warmonger (administrator)
2015-02-09 15:03
edited on: 2015-02-09 15:04

Hey it works now. Was there a reason to change this line before?

However, def in world view is still incorrect.

(0005431)
Fay (developer)
2015-02-09 15:18

Well, THAT was the reason. :)
For me, flags in normal view work both with and without alpha blitting. In world view only alpha blitting worked (because wv works slightly differently, since it needs to copy the surfaces when resizing).

I'll look into it.
(0005432)
Fay (developer)
2015-02-09 16:31

I think I found the problem in world view when alpha blitting is off. Apparently SDL loses information about color keying when copying (or scaling?) the surface.
Seems that adding SDL_SetColorKey(...cyan...) on the scaled surface solves the problem. I'll test it some more and push the fix later today.
(0005437)
Fay (developer)
2015-02-09 19:45

Should be fixed in https://github.com/vcmi/vcmi/pull/85 [^]
(0005438)
Warmonger (administrator)
2015-02-09 21:17

It works, thanks!

- Issue History
Date Modified Username Field Change
2015-02-01 18:31 Warmonger New Issue
2015-02-01 18:31 Warmonger File Added: Bug2053.png
2015-02-01 21:39 Fay Note Added: 0005404
2015-02-01 21:41 Fay Status new => feedback
2015-02-02 00:49 SXX Note Added: 0005406
2015-02-02 05:27 Warmonger Note Added: 0005407
2015-02-02 05:27 Warmonger Status feedback => new
2015-02-02 17:01 Fay Note Added: 0005408
2015-02-09 07:49 Warmonger Note Added: 0005426
2015-02-09 08:01 Warmonger Note Edited: 0005426 View Revisions
2015-02-09 11:29 Fay Note Added: 0005427
2015-02-09 15:03 Warmonger Note Added: 0005430
2015-02-09 15:04 Warmonger Note Edited: 0005430 View Revisions
2015-02-09 15:18 Fay Note Added: 0005431
2015-02-09 16:31 Fay Note Added: 0005432
2015-02-09 19:45 Fay Note Added: 0005437
2015-02-09 21:17 Warmonger Note Added: 0005438
2015-02-09 21:17 Warmonger Status new => resolved
2015-02-09 21:17 Warmonger Fixed in Version => 0.97c
2015-02-09 21:17 Warmonger Resolution open => fixed
2015-02-09 21:17 Warmonger Assigned To => Fay
2016-11-11 08:22 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean